aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3lint
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mp3lint')
-rw-r--r--audio/mp3lint/Makefile15
-rw-r--r--audio/mp3lint/pkg-plist8
2 files changed, 14 insertions, 9 deletions
diff --git a/audio/mp3lint/Makefile b/audio/mp3lint/Makefile
index 54752bff5c96..0ba1b534041f 100644
--- a/audio/mp3lint/Makefile
+++ b/audio/mp3lint/Makefile
@@ -10,19 +10,18 @@ MASTER_SITES= http://erislabs.net/ianb/projects/${PORTNAME}/ \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Configurable tool to check collections of audio files
+LICENSE= GPLv2
+
BUILD_DEPENDS= libmp3-archive-perl>=0:${PORTSDIR}/audio/libmp3-archive-perl
-RUN_DEPENDS= libmp3-archive-perl>=0:${PORTSDIR}/audio/libmp3-archive-perl
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-NO_STAGE= yes
USE_PERL5= configure
USES= perl5
-MAN1= mp3lintsum.1 mp3lintskip.1 mp3lint.1
-MAN3= mp3lint-tools.3
-MAN5= mp3lintrc.5
-
post-patch:
- @${REINPLACE_CMD} -e '/^DESTINSTALLSYSCONFDIR/ s|DESTDIR|PREFIX|' \
- ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -e '/^INSTALLSYSCONFDIR/ s|/etc|${PREFIX}&|' ${WRKSRC}/Makefile.PL
+# It fails to build with error message as follows:
+# Can't write-open blib/man5/mp3lintrc.5: No such file or directory at /usr/local/lib/perl5/5.xx.y/ExtUtils/Command/MM.pm line zzz.
+ @${MKDIR} ${WRKSRC}/blib/man5/
.include <bsd.port.mk>
diff --git a/audio/mp3lint/pkg-plist b/audio/mp3lint/pkg-plist
index 135a6e998d52..acce8da4fed2 100644
--- a/audio/mp3lint/pkg-plist
+++ b/audio/mp3lint/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
bin/mp3lint
bin/mp3lintsum
bin/mp3lintskip
@@ -19,6 +18,13 @@ etc/mp3lintrc
%%SITE_PERL%%/MP3/Archive/Lint/Tools/Ogg.pm
%%SITE_PERL%%/MP3/Archive/Lint/Tools/Wav.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/mp3lint/.packlist
+%%PERL5_MAN3%%/mp3lint-tools.3.gz
+man/man1/mp3lint.1.gz
+man/man1/mp3lintskip.1.gz
+man/man1/mp3lintsum.1.gz
+man/man5/mp3lintrc.5.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/mp3lint
@dirrmtry %%SITE_PERL%%/MP3/Archive/Lint/Tools
@dirrmtry %%SITE_PERL%%/MP3/Archive/Lint
+@dirrmtry %%SITE_PERL%%/MP3/Archive
+@dirrmtry %%SITE_PERL%%/MP3