aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3mover/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mp3mover/Makefile')
-rw-r--r--audio/mp3mover/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/audio/mp3mover/Makefile b/audio/mp3mover/Makefile
index f091489ff390..b54aab6b039a 100644
--- a/audio/mp3mover/Makefile
+++ b/audio/mp3mover/Makefile
@@ -9,7 +9,8 @@
PORTNAME= mp3mover
PORTVERSION= 2.1.1
CATEGORIES= audio perl5
-MASTER_SITES= http://www.doc.ic.ac.uk/~jsm00/scripts/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mediamover
MAINTAINER= ports@FreeBSD.org
COMMENT= Rename mp3s and manipulate them
@@ -19,15 +20,19 @@ RUN_DEPENDS= ${SITE_PERL}/MP3/Tag.pm:${PORTSDIR}/audio/p5-tagged
USE_PERL5= yes
NO_BUILD= yes
+PORTDOCS= readme
+PLIST_FILES= bin/mp3mover \
+ %%DATADIR%%/sample-.mp3moverrc \
+ %%DATADIR%%/shellperfect-.mp3moverrc
+PLIST_DIRS= %%DATADIR%%
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/mp3mover.pl ${PREFIX}/bin/mp3mover
@${MKDIR} ${DATADIR}
- ${CP} ${WRKSRC}/sample-.mp3moverrc ${DATADIR}
- ${CP} ${WRKSRC}/shellperfect-.mp3moverrc ${DATADIR}
-
-post-install:
+ ${INSTALL_DATA} ${WRKSRC}/sample-.mp3moverrc ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/shellperfect-.mp3moverrc ${DATADIR}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}
.endif