aboutsummaryrefslogtreecommitdiff
path: root/audio/musiccontrol/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/musiccontrol/Makefile')
-rw-r--r--audio/musiccontrol/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/audio/musiccontrol/Makefile b/audio/musiccontrol/Makefile
index 2c51a22c8fd6..2cd43ec4b069 100644
--- a/audio/musiccontrol/Makefile
+++ b/audio/musiccontrol/Makefile
@@ -18,16 +18,15 @@ RUN_DEPENDS= ${LOCALBASE}/bin/mpg123:${PORTSDIR}/audio/mpg123 \
${LOCALBASE}/bin/simplemod:${PORTSDIR}/audio/simplemod
USE_JAVA= yes
-NO_STAGE= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
PLIST_FILES= share/java/classes/MusicControl-${PORTVERSION}.jar bin/musiccontrol
do-install:
- @${MKDIR} ${JAVAJARDIR}
- ${INSTALL_DATA} ${DISTDIR}/MusicControl-${PORTVERSION}.jar ${JAVAJARDIR}/
+ @${MKDIR} ${STAGEDIR}${JAVAJARDIR}
+ ${INSTALL_DATA} ${DISTDIR}/MusicControl-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/
${SED} 's,%%LOCALBASE%%,${LOCALBASE},g ; s,%%JAVAJARDIR%%,${JAVAJARDIR},g' \
${FILESDIR}/musiccontrol > ${WRKDIR}/musiccontrol
- ${INSTALL_SCRIPT} ${WRKDIR}/musiccontrol ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/musiccontrol ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>