aboutsummaryrefslogtreecommitdiff
path: root/audio/nas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/nas/Makefile')
-rw-r--r--audio/nas/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/audio/nas/Makefile b/audio/nas/Makefile
index 9b2642c322ea..101e110b7bc7 100644
--- a/audio/nas/Makefile
+++ b/audio/nas/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= nas
-PORTVERSION= 1.4
+PORTVERSION= 1.4.1
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
- http://radscan.com/nas/
+MASTER_SITES= http://radscan.com/nas/ \
+ ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= audio/nas
EXTRACT_SUFX= .src.tar.gz
@@ -70,6 +70,14 @@ MAN3= AuAnyEvent.3 AuBucketAttributes.3 AuCloseServer.3 \
SoundReadFile.3 SoundRewindFile.3 SoundSeekFile.3 \
SoundStringToFileFormat.3 SoundTellFile.3 SoundWriteFile.3
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} > 3
+PLIST_SUB+= XFREE4:=""
+.else
+PLIST_SUB+= XFREE4:="@comment "
+.endif
+
post-patch:
@find ${WRKSRC} -name '*.[ch]' | xargs \
${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g"
@@ -77,4 +85,4 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>