aboutsummaryrefslogtreecommitdiff
path: root/audio/ncmpc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ncmpc/Makefile')
-rw-r--r--audio/ncmpc/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/audio/ncmpc/Makefile b/audio/ncmpc/Makefile
index e08fcd0ca8b8..83edcd9fcc9c 100644
--- a/audio/ncmpc/Makefile
+++ b/audio/ncmpc/Makefile
@@ -21,7 +21,8 @@ CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
OPTIONS= NLS "Native language support" on \
- CLOCK_SCREEN "Enable clock screen" on
+ CLOCK_SCREEN "Enable clock screen" on \
+ SEARCH_SCREEN "Enable search screen" on
.include <bsd.port.pre.mk>
@@ -47,6 +48,10 @@ PLIST_FILES+=share/locale/${language}/LC_MESSAGES/ncmpc.mo
CONFIGURE_ARGS+=--enable-clock-screen
.endif
+.if !defined(WITHOUT_SEARCH_SCREEN)
+CONFIGURE_ARGS+=--enable-search-screen
+.endif
+
MAN1= ncmpc.1
do-install: