aboutsummaryrefslogtreecommitdiff
path: root/audio/openal-soft/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'audio/openal-soft/files/patch-CMakeLists.txt')
-rw-r--r--audio/openal-soft/files/patch-CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/audio/openal-soft/files/patch-CMakeLists.txt b/audio/openal-soft/files/patch-CMakeLists.txt
index d111cfbe7bd3..4f330d5f9840 100644
--- a/audio/openal-soft/files/patch-CMakeLists.txt
+++ b/audio/openal-soft/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2016-01-25 03:12:39 UTC
+--- CMakeLists.txt.orig 2017-07-30 05:09:21 UTC
+++ CMakeLists.txt
-@@ -582,10 +582,6 @@ int main()
+@@ -646,10 +646,6 @@ int main()
CHECK_SYMBOL_EXISTS(pthread_mutex_timedlock pthread.h HAVE_PTHREAD_MUTEX_TIMEDLOCK)
@@ -11,12 +11,12 @@
ENDIF()
# Check for a 64-bit type
-@@ -1184,7 +1180,7 @@ IF(ALSOFT_INSTALL)
- DESTINATION include/AL
+@@ -1322,7 +1318,7 @@ IF(ALSOFT_INSTALL)
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/AL
)
INSTALL(FILES "${OpenAL_BINARY_DIR}/openal.pc"
-- DESTINATION "lib${LIB_SUFFIX}/pkgconfig")
+- DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
+ DESTINATION "libdata/pkgconfig")
- ENDIF()
-
-
+ IF(TARGET soft_oal)
+ INSTALL(TARGETS soft_oal
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}