aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Audio-MPD
diff options
context:
space:
mode:
Diffstat (limited to 'audio/p5-Audio-MPD')
-rw-r--r--audio/p5-Audio-MPD/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/audio/p5-Audio-MPD/Makefile b/audio/p5-Audio-MPD/Makefile
index afd6db401209..20b1762902b5 100644
--- a/audio/p5-Audio-MPD/Makefile
+++ b/audio/p5-Audio-MPD/Makefile
@@ -29,7 +29,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Corpus-Audio-MPD>=1.113282:${PORTSDIR}/audio/p5-Test-Corpus-Audio-MPD
-PERL_MODBUILD= yes
+PERL_MODBUILD= 5.10.0+
MAN1= mpd-dynamic.1 \
mpd-rate.1
@@ -38,4 +38,10 @@ MAN3= Audio::MPD.3 \
Audio::MPD::Playlist.3 \
Audio::MPD::Types.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>