aboutsummaryrefslogtreecommitdiff
path: root/audio/pd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/pd/Makefile')
-rw-r--r--audio/pd/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/pd/Makefile b/audio/pd/Makefile
index 3ef1d77b2bab..9f468869c9dd 100644
--- a/audio/pd/Makefile
+++ b/audio/pd/Makefile
@@ -30,6 +30,12 @@ USE_X_PREFIX= yes
USE_AUTOCONF_VER= 259
WRKSRC= ${WRKDIR}/pd-0.37-1test1/src
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
pre-patch:
${RM} -f ${WRKSRC}/configure
@@ -86,4 +92,4 @@ do-install:
${MKDIR} ${DATADIR}
cd ${WRKSRC}/../extra && ${PAX} -r -w * ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>