aboutsummaryrefslogtreecommitdiff
path: root/audio/pd
diff options
context:
space:
mode:
Diffstat (limited to 'audio/pd')
-rw-r--r--audio/pd/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/pd/Makefile b/audio/pd/Makefile
index c4418fa7f46a..1a4db6b5a30d 100644
--- a/audio/pd/Makefile
+++ b/audio/pd/Makefile
@@ -35,9 +35,10 @@ pre-configure:
${CHMOD} +x ${WRKSRC}/${CONFIGURE_SCRIPT}
post-configure:
- ${PERL} -pi -e \
-"s:^INCLUDE = :INCLUDE = -I${LOCALBASE}/include/tk8.3 -I${LOCALBASE}/include/tcl8.3 -I${X11BASE}/include :g; s:^LIB =:LIB =${PTHREAD_LIBS}:g; s:^CFLAGS =:CFLAGS+=${PTHREAD_CFLAGS}:g" \
- ${WRKSRC}/makefile
+ ${CP} ${WRKSRC}/makefile ${WRKSRC}/makefile.orig
+ ${SED} -e \
+"s:^INCLUDE = :INCLUDE = -I${LOCALBASE}/include/tk8.3 -I${LOCALBASE}/include/tcl8.3 -I${X11BASE}/include :g; s:^LIB =:LIB =${PTHREAD_LIBS}:g; s:^CFLAGS =:CFLAGS+=${PTHREAD_CFLAGS}:g" < ${WRKSRC}/makefile.orig \
+ > ${WRKSRC}/makefile
pre-install:
${RM} -f ${PLIST}