aboutsummaryrefslogtreecommitdiff
path: root/audio/pd
diff options
context:
space:
mode:
Diffstat (limited to 'audio/pd')
-rw-r--r--audio/pd/Makefile8
-rw-r--r--audio/pd/files/patch-src_s_freebsd.c21
2 files changed, 18 insertions, 11 deletions
diff --git a/audio/pd/Makefile b/audio/pd/Makefile
index eac3c9c03609..e82411689ee7 100644
--- a/audio/pd/Makefile
+++ b/audio/pd/Makefile
@@ -17,12 +17,6 @@ COMMENT= Pure Data, a MIDI-capable real-time audio processor/synthesizer
LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83 \
tk83:${PORTSDIR}/x11-toolkits/tk83
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -ltk83 -ltcl83"
@@ -92,4 +86,4 @@ do-install:
${MKDIR} ${DATADIR}
cd ${WRKSRC}/../extra && pax -r -w * ${DATADIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/pd/files/patch-src_s_freebsd.c b/audio/pd/files/patch-src_s_freebsd.c
index 7be4999c58bf..c07683d2053f 100644
--- a/audio/pd/files/patch-src_s_freebsd.c
+++ b/audio/pd/files/patch-src_s_freebsd.c
@@ -1,5 +1,7 @@
---- src/s_freebsd.c.orig Sun Oct 20 02:49:11 2002
-+++ src/s_freebsd.c Sun Oct 20 02:53:24 2002
+$FreeBSD$
+
+--- src/s_freebsd.c.orig Fri May 23 00:52:34 2003
++++ src/s_freebsd.c Fri May 23 01:01:59 2003
@@ -32,7 +32,8 @@
* 1311:forum::für::umläute:2001
*/
@@ -10,7 +12,18 @@
#if (defined(ALSA01) || defined(ALSA99))
#define ALSA
-@@ -865,7 +866,8 @@
+@@ -762,8 +762,10 @@
+ #endif
+
+ #ifdef _POSIX_MEMLOCK
++#if _POSIX_MEMLOCK != -1
+ if (mlockall(MCL_FUTURE) != -1)
+ fprintf(stderr, "memory locking enabled.\n");
++#endif
+ #endif
+ }
+
+@@ -865,7 +868,8 @@
}
else
{
@@ -20,7 +33,7 @@
dev->d_bytespersamp = 2;
}
param = wantformat;
-@@ -2747,7 +2749,7 @@
+@@ -2747,7 +2751,7 @@
/* use ctrlpanel to change, experiment, channels 1 */