aboutsummaryrefslogtreecommitdiff
path: root/audio/pocketsphinx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/pocketsphinx/Makefile')
-rw-r--r--audio/pocketsphinx/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/pocketsphinx/Makefile b/audio/pocketsphinx/Makefile
new file mode 100644
index 000000000000..635dd8446632
--- /dev/null
+++ b/audio/pocketsphinx/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: pocketsphinx
+# Date created: 3 Jan 2008
+# Whom: Richard Neese
+#
+# $FreeBSD$
+#
+
+PORTNAME= pocketsphinx
+PORTVERSION= 0.4.1
+CATEGORIES= audio accessibility
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cmusphinx
+
+MAINTAINER= r.neese@gmail.com
+COMMENT= Speech recognition system
+
+LIB_DEPENDS= sphinxfe.0:${PORTSDIR}/audio/sphinxbase
+
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/sphinxbase" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAKE_ENV= MKDIR="${MKDIR}" \
+ OSVERSION=${OSVERSION} \
+ CXX="${CXX}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>