aboutsummaryrefslogtreecommitdiff
path: root/audio/pure-audio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/pure-audio/Makefile')
-rw-r--r--audio/pure-audio/Makefile37
1 files changed, 0 insertions, 37 deletions
diff --git a/audio/pure-audio/Makefile b/audio/pure-audio/Makefile
deleted file mode 100644
index a6051441a431..000000000000
--- a/audio/pure-audio/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# Created by: Zhihao Yuan <lichray@gmail.com>
-# $FreeBSD$
-
-PORTNAME= pure-audio
-PORTVERSION= 0.5
-PORTREVISION= 4
-CATEGORIES= audio
-MASTER_SITES= https://cdn.bitbucket.org/purelang/pure-lang/downloads/
-DIST_SUBDIR= pure
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Digital audio interface for the Pure language
-
-LICENSE= BSD3CLAUSE
-
-BROKEN= Unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2015-11-26
-LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio \
- libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
- libsndfile.so:${PORTSDIR}/audio/libsndfile \
- libfftw3.so:${PORTSDIR}/math/fftw3
-
-USES= pure
-
-PORTDOCS= README
-PORTEXAMPLES= *
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
-
-.include <bsd.port.mk>