aboutsummaryrefslogtreecommitdiff
path: root/audio/py-vorbis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/py-vorbis/Makefile')
-rw-r--r--audio/py-vorbis/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/audio/py-vorbis/Makefile b/audio/py-vorbis/Makefile
new file mode 100644
index 000000000000..ce36703d3f29
--- /dev/null
+++ b/audio/py-vorbis/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pyvorbis
+# Date created: 23 Sep 2002
+# Whom: makeport.pl
+#
+# $FreeBSD$
+#
+
+PORTNAME= vorbis
+PORTVERSION= 1.0
+CATEGORIES= audio
+MASTER_SITES= http://www.andrewchatham.com/pyogg/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyvorbis-${PORTVERSION}
+
+MAINTAINER= nbm@FreeBSD.org
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/ogg/_oggmodule.so:${PORTSDIR}/audio/py-ogg
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ogg/_oggmodule.so:${PORTSDIR}/audio/py-ogg
+LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+do-configure:
+ @cd ${WRKSRC} && ${PYTHON_CMD} config_unix.py
+
+.include <bsd.port.mk>