aboutsummaryrefslogtreecommitdiff
path: root/audio/raop_play/files/patch-rendezvous_Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'audio/raop_play/files/patch-rendezvous_Makefile.in')
-rw-r--r--audio/raop_play/files/patch-rendezvous_Makefile.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/raop_play/files/patch-rendezvous_Makefile.in b/audio/raop_play/files/patch-rendezvous_Makefile.in
new file mode 100644
index 000000000000..5067dc748e32
--- /dev/null
+++ b/audio/raop_play/files/patch-rendezvous_Makefile.in
@@ -0,0 +1,30 @@
+--- rendezvous/Makefile.in.orig 2005-12-16 14:17:02 UTC
++++ rendezvous/Makefile.in
+@@ -1,6 +1,7 @@
+ SHELL = @SHELL@
+ CC = @CC@
+ DEFS = @DEFS@
++LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+@@ -9,7 +10,7 @@ INSTALL = @INSTALL@
+ top_srcdir = @top_srcdir@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+
+-CFLAGS += -Wall -DNOT_HAVE_SA_LEN
++CFLAGS += -Wall
+
+ TARGET = mDNSClient
+ DESTDIR =
+@@ -17,8 +18,8 @@ DESTDIR =
+ all: $(TARGET)
+
+
+-mDNSClient: mDNSPosix.o mDNSUNP.o ExampleClientApp.o mDNS.o Client.o
+- $(CC) $(LFLAGS) $^ -o $@
++mDNSClient: mDNSPosix.o mDNSUNP.o ExampleClientApp.o mDNS.o Client.o getline.o
++ $(CC) $(LDFLAGS) mDNSPosix.o mDNSUNP.o ExampleClientApp.o mDNS.o Client.o getline.o -o $@
+
+ install:
+ $(mkinstalldirs) $(DESTDIR)$(bindir)/