aboutsummaryrefslogtreecommitdiff
path: root/audio/rat/files/patch-ac
diff options
context:
space:
mode:
Diffstat (limited to 'audio/rat/files/patch-ac')
-rw-r--r--audio/rat/files/patch-ac94
1 files changed, 86 insertions, 8 deletions
diff --git a/audio/rat/files/patch-ac b/audio/rat/files/patch-ac
index 32e545a50c89..4f65b57ba717 100644
--- a/audio/rat/files/patch-ac
+++ b/audio/rat/files/patch-ac
@@ -1,10 +1,88 @@
---- rat/config_unix.h.orig Sat Nov 27 18:27:56 1999
-+++ rat/config_unix.h Sat Nov 27 18:33:33 1999
-@@ -17,6 +17,7 @@
+--- rat/configure.in.pre Sun Sep 17 02:34:18 2000
++++ rat/configure.in Sun Sep 17 02:36:23 2000
+@@ -280,12 +280,12 @@
+ # We could be dealing with a source installation or a full installation.
+ # Expect a source installation to have headers in TCL8_HOME/generic and libs in
+ # TCL8_HOME/unix. A full installation should have headers in
+-# INSTDIR/include/tcl8.0, or INSTDIR/include, and have libraries be in
++# INSTDIR/include/tcl8.2, or INSTDIR/include, and have libraries be in
+ # INSTDIR/lib.
+ #------------------------------------------------------------------------------
+ PARENT=`echo $PWD | sed -e 's%/[[^/]]*$%%'`
+-TCL_INC=${PARENT}/tcl-8.0
+-TCL_LIB=${PARENT}/tcl-8.0
++TCL_INC=${PARENT}/tcl-8.2
++TCL_LIB=${PARENT}/tcl-8.2
- #include <limits.h>
- #include <sys/types.h>
-+#include <sys/signal.h>
- #include <sys/time.h>
- #include <sys/resource.h>
+ AC_ARG_WITH(tcl,
+ [ --with-tcl=DIR specify location of Tcl installation],
+@@ -295,7 +295,7 @@
+ #-----------------------------------------------------------------------------
+ # Depending on config expect tcl.h to be tcl source dir or include path
+ #-----------------------------------------------------------------------------
+-for i in $TCL_INC/generic $TCL_INC/include/tcl8.0 $TCL_INC/include $TCL_INC
++for i in $TCL_INC/generic $TCL_INC/include/tcl8.2 $TCL_INC/include $TCL_INC
+ do
+ if test -d $i ; then
+ TCL_INC=$i
+@@ -330,7 +330,7 @@
+ SAVED_LIBS=$LIBS
+ LIBS=""
+ FOUND_TCL_LIB=no
+-AC_SEARCH_LIBS(Tcl_Init, tcl8.0 tcl80,
++AC_SEARCH_LIBS(Tcl_Init, tcl8.2 tcl82,
+ FOUND_TCL_LIB=yes,
+ ,
+ -L${TCL_LIB} ${SAVED_LIBS} -lm)
+@@ -346,8 +346,8 @@
+ exit
+ fi
+-TK_INC=${PARENT}/tk-8.0
+-TK_LIB=${PARENT}/tk-8.0
++TK_INC=${PARENT}/tk-8.2
++TK_LIB=${PARENT}/tk-8.2
+
+ AC_ARG_WITH(tk,
+ [ --with-tk=DIR specify location of Tk installation],
+@@ -359,7 +359,7 @@
+ # include tcl.h, Xlib.h, Xutil.h before tk.h.
+ #-----------------------------------------------------------------------------
+ FOUND_TK_INC=0
+-for i in $TK_INC/generic $TK_INC/include/tk8.0 $TK_INC/include $TK_INC
++for i in $TK_INC/generic $TK_INC/include/tk8.2 $TK_INC/include $TK_INC
+ do
+ AC_MSG_CHECKING(for $i/tk.h)
+ if test -r $i/tk.h ; then
+@@ -391,7 +391,7 @@
+ SAVED_LIBS=$LIBS
+ LIBS=""
+ FOUND_TK_LIB=no
+-AC_SEARCH_LIBS(Tk_Init, tk8.0 tk80,
++AC_SEARCH_LIBS(Tk_Init, tk8.2 tk82,
+ FOUND_TK_LIB=yes,
+ ,
+ -L${TK_LIB} ${TCL_LIB} $X_LIBS $X_PRE_LIBS -lXext -lX11 $X_EXTRA_LIBS ${SAVED_LIBS} -lm)
+@@ -466,20 +466,8 @@
+ COMMON_LIB=${COMMON_LIB}/lib
+ fi
+
+-AC_CHECK_LIB(uclmmbase,
+- mbus_init,
+- [
+- EXTERNAL_DEP="${EXTERNAL_DEP} ${COMMON_LIB}/libuclmmbase.a"
+- COMMON_LIB="-L${COMMON_LIB} -luclmmbase"
+- ],
+- [
+- echo "Could not find libuclmmbase.a. One of the following halted progess:"
+- echo " (a) Library is not installed."
+- echo " (b) Library is not built or not in expected location (--with-common=DIR)."
+- echo " (c) this script failed to see it (please inform rat-trap@cs.ucl.ac.uk)."
+- exit
+- ],
+- -L${COMMON_LIB})
++EXTERNAL_DEP="${EXTERNAL_DEP} ${COMMON_LIB}/libuclmmbase.a"
++COMMON_LIB="-L${COMMON_LIB} -luclmmbase"
+
+ AC_SUBST(COMMON_INC)
+ AC_SUBST(COMMON_LIB)