aboutsummaryrefslogtreecommitdiff
path: root/audio/rio500/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/rio500/Makefile')
-rw-r--r--audio/rio500/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/audio/rio500/Makefile b/audio/rio500/Makefile
index 55d077de6d7f..bbe15ce5a997 100644
--- a/audio/rio500/Makefile
+++ b/audio/rio500/Makefile
@@ -20,10 +20,13 @@ CONFIGURE_ARGS= --with-devicepath='/dev' \
--with-deviceentry='urio0' \
--with-id3support
+USE_REINPLACE= yes
+
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
-.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s,byteswap.h,sys/endian.h," \
+ ${WRKSRC}/lib/libfon.c \
+ ${WRKSRC}/lib/librio500.c
.include <bsd.port.post.mk>