aboutsummaryrefslogtreecommitdiff
path: root/audio/rsynth/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/rsynth/Makefile')
-rw-r--r--audio/rsynth/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/audio/rsynth/Makefile b/audio/rsynth/Makefile
index fdf82b18215b..4519037ab93a 100644
--- a/audio/rsynth/Makefile
+++ b/audio/rsynth/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rsynth
PORTVERSION= 2.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio accessibility
MASTER_SITES= ftp://svr-ftp.eng.cam.ac.uk/pub/comp.speech/synthesis/ \
ftp://ftp.enst.fr/pub/unix/multimedia/
@@ -11,14 +11,27 @@ MASTER_SITES= ftp://svr-ftp.eng.cam.ac.uk/pub/comp.speech/synthesis/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Speech synthesizer
-LIB_DEPENDS= libgdbm.so:databases/gdbm \
- libaudio.so:audio/nas
+LICENSE= PD
+
+OPTIONS_DEFINE= DB NAS SNDIO
+OPTIONS_SUB= yes
+
+DB_DESC= Build dictionary database tools
+DB_LIB_DEPENDS= libgdbm.so:databases/gdbm
+DB_CONFIGURE_ENV_OFF= ac_cv_lib_gdbm_gdbm_open=no
+NAS_LIB_DEPENDS= libaudio.so:audio/nas
+NAS_CONFIGURE_ENV_OFF= ac_cv_header_audio_audiolib_h=no
+SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
+SNDIO_MAKE_ENV= SAY_LIBS=-lsndio
USES= autoreconf
GNU_CONFIGURE= yes
-pre-configure:
- @${CP} ${FILESDIR}/freebsdplay.c ${WRKSRC}/config/freebsdplay.c
+pre-configure-SNDIO-on:
+ @${CP} ${FILESDIR}/sndioplay.c ${WRKSRC}/config/freebsdplay.c
+
+pre-configure-SNDIO-off:
+ @${CP} ${FILESDIR}/ossplay.c ${WRKSRC}/config/freebsdplay.c
post-configure:
@${REINPLACE_CMD} -E 's,(BIN|LIB)_DIR\),DESTDIR\)$$\(&,g' \