aboutsummaryrefslogtreecommitdiff
path: root/audio/sbagen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/sbagen/Makefile')
-rw-r--r--audio/sbagen/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/audio/sbagen/Makefile b/audio/sbagen/Makefile
index 04d67c1d7168..ace8eadc8bab 100644
--- a/audio/sbagen/Makefile
+++ b/audio/sbagen/Makefile
@@ -24,13 +24,15 @@ SHAREFILES= t-alpha t-beta t-calm t-calm2 t-delta t-focus t-focus-1 \
DOCFILES= sbagen.txt theory.txt theory2.txt
+USE_REINPLACE= yes
+
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/sbagen.c
post-patch:
.for F in ${SHAREFILES}
- @${PERL} -pi -e 's,/bin/bash,/bin/sh,g' ${WRKSRC}/$F
+ @${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,g' ${WRKSRC}/$F
.endfor
do-build: