aboutsummaryrefslogtreecommitdiff
path: root/audio/soundtracker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/soundtracker/Makefile')
-rw-r--r--audio/soundtracker/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/audio/soundtracker/Makefile b/audio/soundtracker/Makefile
index 73dfd15439fd..58eac98eff15 100644
--- a/audio/soundtracker/Makefile
+++ b/audio/soundtracker/Makefile
@@ -15,6 +15,8 @@ MAINTAINER= kzentner@u.washington.edu
USE_X_PREFIX= yes
USE_GNOMENG= yes
WANT_GNOME= yes
+USE_GNOME= gtk12
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -22,18 +24,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
.if ${HAVE_GNOME:Mgnomelibs}!=""
-USE_GNOME= gtk12 esound
+USE_GNOME= gnomelibs esound gnomeprefix gnomehack
CONFIGURE_ARGS+=--enable-gnome
PKGNAMESUFFIX= -gnome
.else
CONFIGURE_ARGS+=--disable-gnome
.endif
-pre-patch:
- @${PERL} -pi -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.post.mk>