aboutsummaryrefslogtreecommitdiff
path: root/audio/spiralsynth/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/spiralsynth/Makefile')
-rw-r--r--audio/spiralsynth/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index 9c808e3420b8..3a14db670757 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -16,6 +16,12 @@ COMMENT= MIDI-capable synthesizer for X
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
GNU_CONFIGURE= yes
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
@@ -69,4 +75,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>