aboutsummaryrefslogtreecommitdiff
path: root/audio/streamtuner/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/streamtuner/Makefile')
-rw-r--r--audio/streamtuner/Makefile66
1 files changed, 31 insertions, 35 deletions
diff --git a/audio/streamtuner/Makefile b/audio/streamtuner/Makefile
index cfc6dfef69e3..c45d8be4c9b1 100644
--- a/audio/streamtuner/Makefile
+++ b/audio/streamtuner/Makefile
@@ -1,85 +1,81 @@
-# New ports collection makefile for: streamtuner
-# Date created: 02 Apr 2002
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
-PORTNAME= streamtuner
-PORTVERSION= 0.99.99
+PORTNAME= streamtuner
+PORTVERSION= 0.99.99
PORTREVISION= 19
-CATEGORIES= audio www
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+CATEGORIES= audio www
+MASTER_SITES= SAVANNAH
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A GTK+ stream directory browser
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GTK+ stream directory browser
-BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
+BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
-USE_GNOME= gtk20 gnomehack gnomeprefix
-USE_GMAKE= yes
-INSTALLS_OMF= yes
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+USE_GNOME= gtk20 gnomehack gnomeprefix
+USE_GMAKE= yes
+INSTALLS_OMF= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= SHOUTCAST LIVE365 XIPH LOCAL LOCAL_METADATA
OPTIONS_DEFAULT= SHOUTCAST LIVE365 XIPH LOCAL LOCAL_METADATA
SHOUTCAST_DESC= SHOUTcast plugin
LIVE365_DESC= Live365 plugin
LOCAL_DESC= Local plugin
-LOCAL_METADATA_DESC= metadata support for the Local plugin
+LOCAL_METADATA_DESC= Metadata support for the Local plugin
XIPH_DESC= Xiph plugin
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSHOUTCAST}
-PLIST_SUB+= SHOUTCAST=""
+PLIST_SUB+= SHOUTCAST=""
.else
CONFIGURE_ARGS+= --disable-shoutcast
-PLIST_SUB+= SHOUTCAST="@comment "
+PLIST_SUB+= SHOUTCAST="@comment "
.endif
.if ${PORT_OPTIONS:MLIVE365}
-PLIST_SUB+= LIVE365=""
+PLIST_SUB+= LIVE365=""
.else
CONFIGURE_ARGS+= --disable-live365
-PLIST_SUB+= LIVE365="@comment "
+PLIST_SUB+= LIVE365="@comment "
.endif
.if ${PORT_OPTIONS:MXIPH}
-PLIST_SUB+= XIPH=""
-USE_GNOME+= libxml2
+PLIST_SUB+= XIPH=""
+USE_GNOME+= libxml2
.else
CONFIGURE_ARGS+= --disable-xiph
-PLIST_SUB+= XIPH="@comment "
+PLIST_SUB+= XIPH="@comment "
.endif
.if ${PORT_OPTIONS:MLOCAL}
-PLIST_SUB+= LOCAL=""
+PLIST_SUB+= LOCAL=""
.if ${PORT_OPTIONS:MLOCAL_METADATA}
-LIB_DEPENDS+= tag_c:${PORTSDIR}/audio/taglib
+LIB_DEPENDS+= tag_c:${PORTSDIR}/audio/taglib
.else
CONFIGURE_ARGS+= --disable-local-metadata
.endif
.else
CONFIGURE_ARGS+= --disable-local
-PLIST_SUB+= LOCAL="@comment "
+PLIST_SUB+= LOCAL="@comment "
.endif
.if ${PORT_OPTIONS:MPYTHON}
-PLIST_SUB+= PYTHON=""
-USE_PYTHON= 2.5+
+PLIST_SUB+= PYTHON=""
+USE_PYTHON= 2.5+
# we need to manually include this, because USE_PYTHON is defined
# after including bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.python.mk"
-USE_GNOME+= pygtk2
+USE_GNOME+= pygtk2
.else
CONFIGURE_ARGS+= --disable-python
-PLIST_SUB+= PYTHON="@comment "
+PLIST_SUB+= PYTHON="@comment "
.endif
post-patch: