aboutsummaryrefslogtreecommitdiff
path: root/audio/tclmidi/files/patch-Makefile.ins
diff options
context:
space:
mode:
Diffstat (limited to 'audio/tclmidi/files/patch-Makefile.ins')
-rw-r--r--audio/tclmidi/files/patch-Makefile.ins62
1 files changed, 40 insertions, 22 deletions
diff --git a/audio/tclmidi/files/patch-Makefile.ins b/audio/tclmidi/files/patch-Makefile.ins
index 037b99198ab6..39cdd3df4cfc 100644
--- a/audio/tclmidi/files/patch-Makefile.ins
+++ b/audio/tclmidi/files/patch-Makefile.ins
@@ -1,6 +1,6 @@
---- Makefile.in 1996-10-09 23:32:36.000000000 -0400
-+++ Makefile.in 2012-04-07 12:07:34.000000000 -0400
-@@ -11,7 +11,7 @@
+--- Makefile.in.orig 1996-10-10 03:32:36 UTC
++++ Makefile.in
+@@ -11,7 +11,7 @@ SCRIPTS = midtotcl minfo mplay mrec
# The directory containing the Tcl library archive file appropriate
# for this version of Tk:
@@ -9,7 +9,7 @@
#----------------------------------------------------------------
# The information below is modified by the configure script when
-@@ -35,8 +35,9 @@
+@@ -35,8 +35,9 @@ srcdir = @srcdir@
VPATH = @srcdir@
CFLAGS = @CFLAGS@ @DEFS@
@@ -20,7 +20,7 @@
TCLMFILES = tclmCmd.o tclmUtil.o tclmEvnt.o tclmPlay.o tclmPtch.o TclmIntp.o
TCLMFILES_SRC = tclmCmd.cxx tclmUtil.cxx tclmEvnt.cxx tclmPlay.cxx \
-@@ -61,7 +62,7 @@
+@@ -61,7 +62,7 @@ pkgIndex.tcl: $(PROJ_LIB_NAME)
@echo 'pkg_mkIndex . $(PROJ_LIB_NAME)' | @TCLSH_PATH@
.cxx.o:
@@ -29,7 +29,7 @@
$(PROJ_LIB_NAME): events/objs smf/objs \
song/objs device/objs patch/objs rb/objs $(TCLMFILES)
-@@ -101,7 +102,7 @@
+@@ -101,7 +102,7 @@ midtotcl: midtotcl.dist
install: $(PROJ_LIB_NAME) $(SCRIPTS)
-mkdir -p $(prefix)$(libdir)/tclmidi
@@ -38,7 +38,7 @@
echo 'pkg_mkIndex $(prefix)$(libdir)/tclmidi \
$(PROJECT)*${SHLIB_SUFFIX}' | @TCLSH_PATH@
cd man; $(MAKE) install
-@@ -128,7 +129,7 @@
+@@ -128,7 +129,7 @@ depend:
sed "/[#]# Dependancies/,$$$$d" < Makefile > Makefile.tmp
echo >> Makefile.tmp
echo "##" "Dependancies" >> Makefile.tmp
@@ -47,69 +47,87 @@
cp Makefile.tmp Makefile
rm Makefile.tmp
---- device/Makefile.in 1996-10-09 23:32:40.000000000 -0400
-+++ device/Makefile.in 2012-04-07 12:13:09.000000000 -0400
-@@ -18,4 +18,5 @@
+--- device/Makefile.in.orig 1996-10-10 03:32:40 UTC
++++ device/Makefile.in
+@@ -17,6 +17,7 @@ CFLAGS = @CFLAGS@ @DEFS@
+ CC_SWITCHES = @CFLAGS@ @DEFS@ -I${TCL_GENERIC_DIR} ${SHLIB_CFLAGS} \
-I$(srcdir)/../events -I$(srcdir)/../rb -I$(srcdir)/../patch \
-I$(srcdir)/../smf -I$(srcdir)/../song -I$(srcdir)/.. -I$(srcdir)
+CXX_SWITCHES= ${CC_SWITCHES} ${CXXFLAGS}
DEVICEFILES = MidiDev.o TclmDr75.o
-@@ -25,5 +26,5 @@
+ DEVICEFILES_SRC = MidiDev.cxx TclmDr75.cxx
+@@ -24,7 +25,7 @@ DEVICEFILES_SRC = MidiDev.cxx TclmDr75.c
+ .SUFFIXES: .cxx $(SUFFIXES)
.cxx.o:
- @CXX@ -c $(CC_SWITCHES) $<
+ @CXX@ -c $(CXX_SWITCHES) $<
objs: $(DEVICEFILES)
-@@ -34,5 +35,5 @@
+ for f in $(DEVICEFILES) ; do echo device/$$f ; done > objs
+@@ -33,7 +34,7 @@ depend:
+ sed "/[#]# Dependancies/,$$$$d" < Makefile > Makefile.tmp
echo >> Makefile.tmp
echo "##" "Dependancies" >> Makefile.tmp
- @CXX@ -M $(CC_SWITCHES) $(DEVICEFILES_SRC) >> Makefile.tmp
+ @CXX@ -M $(CXX_SWITCHES) $(DEVICEFILES_SRC) >> Makefile.tmp
cp Makefile.tmp Makefile
rm Makefile.tmp
---- events/Makefile.in 1996-10-09 23:32:42.000000000 -0400
-+++ events/Makefile.in 2012-04-07 12:15:41.000000000 -0400
-@@ -17,4 +17,5 @@
+
+--- events/Makefile.in.orig 1996-10-10 03:32:42 UTC
++++ events/Makefile.in
+@@ -16,6 +16,7 @@ VPATH = @srcdir@
+ CFLAGS = @CFLAGS@ @DEFS@
CC_SWITCHES = @CFLAGS@ @DEFS@ -I${TCL_GENERIC_DIR} ${SHLIB_CFLAGS} \
-I$(srcdir)/../smf -I$(srcdir)/../song -I$(srcdir)/.. -I$(srcdir)
+CXX_SWITCHES = ${CC_SWITCHES} ${CXXFLAGS}
EVENTFILES = ChanPres.o Event.o MChanPrf.o MCopy.o MCue.o \
-@@ -36,5 +37,5 @@
+ MEOT.o MEvent.o MInstNam.o MKey.o MLyric.o \
+@@ -35,7 +36,7 @@ EVENTFILES_SRC = ChanPres.cxx Event.cxx
+ .SUFFIXES: .cxx $(SUFFIXES)
.cxx.o:
- @CXX@ -c $(CC_SWITCHES) $<
+ @CXX@ -c $(CXX_SWITCHES) $<
objs: $(EVENTFILES)
-@@ -45,5 +46,5 @@
+ for f in $(EVENTFILES) ; do echo events/$$f ; done > objs
+@@ -44,7 +45,7 @@ depend:
+ sed "/[#]# Dependancies/,$$$$d" < Makefile > Makefile.tmp
echo >> Makefile.tmp
echo "##" "Dependancies" >> Makefile.tmp
- @CXX@ -M $(CC_SWITCHES) $(EVENTFILES_SRC) >> Makefile.tmp
+ @CXX@ -M $(CXX_SWITCHES) $(EVENTFILES_SRC) >> Makefile.tmp
cp Makefile.tmp Makefile
rm Makefile.tmp
---- patch/Makefile.in 1996-10-09 23:32:43.000000000 -0400
-+++ patch/Makefile.in 2012-04-07 12:23:29.000000000 -0400
-@@ -17,4 +17,5 @@
+
+--- patch/Makefile.in.orig 1996-10-10 03:32:43 UTC
++++ patch/Makefile.in
+@@ -16,6 +16,7 @@ VPATH = @srcdir@
+ CFLAGS = @CFLAGS@ @DEFS@
CC_SWITCHES = @CFLAGS@ @DEFS@ -I${TCL_GENERIC_DIR} ${SHLIB_CFLAGS} \
-I. -I..
+CXX_SWITCHES = ${CC_SWITCHES} ${CXXFLAGS}
PATCHFILES = GusPatch.o
-@@ -24,5 +25,5 @@
+ PATCHFILES_SRC = GusPatch.cxx
+@@ -23,7 +24,7 @@ PATCHFILES_SRC = GusPatch.cxx
+ .SUFFIXES: .cxx $(SUFFIXES)
.cxx.o:
- @CXX@ -c $(CC_SWITCHES) $<
+ @CXX@ -c $(CXX_SWITCHES) $<
objs: $(PATCHFILES)
-@@ -33,5 +34,5 @@
+ for f in $(PATCHFILES) ; do echo patch/$$f ; done > objs
+@@ -32,7 +33,7 @@ depend:
+ sed "/[#]# Dependancies/,$$$$d" < Makefile > Makefile.tmp
echo >> Makefile.tmp
echo "##" "Dependancies" >> Makefile.tmp
- @CXX@ -M $(CC_SWITCHES) $(PATCHFILES_SRC) >> Makefile.tmp
+ @CXX@ -M $(CXX_SWITCHES) $(PATCHFILES_SRC) >> Makefile.tmp
cp Makefile.tmp Makefile
rm Makefile.tmp
+