aboutsummaryrefslogtreecommitdiff
path: root/audio/vitunes
diff options
context:
space:
mode:
Diffstat (limited to 'audio/vitunes')
-rw-r--r--audio/vitunes/Makefile7
-rw-r--r--audio/vitunes/distinfo6
-rw-r--r--audio/vitunes/files/patch-Makefile11
-rw-r--r--audio/vitunes/files/patch-medialib.h18
-rw-r--r--audio/vitunes/files/patch-uinterface.h11
-rw-r--r--audio/vitunes/files/patch-vitunes.h19
6 files changed, 18 insertions, 54 deletions
diff --git a/audio/vitunes/Makefile b/audio/vitunes/Makefile
index 57b7360dd3a6..032eed551c60 100644
--- a/audio/vitunes/Makefile
+++ b/audio/vitunes/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vitunes
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.2
CATEGORIES= audio
MASTER_SITES= http://www.vitunes.org/files/ \
http://mirror.4bit.ws/ \
@@ -27,8 +27,13 @@ MAKE_ARGS= LDFLAGS_DEPS="-L${LOCALBASE}/lib -lid3tag -lmp4v2 -logg -lvorbis -lvo
ALL_TARGET= vitunes
PLIST_FILES= bin/vitunes
+MAN1= vitunes.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|8|9|g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/audio/vitunes/distinfo b/audio/vitunes/distinfo
index 7ace39ed439f..b3a69c0bec3a 100644
--- a/audio/vitunes/distinfo
+++ b/audio/vitunes/distinfo
@@ -1,3 +1,3 @@
-MD5 (vitunes-1.0.1.tgz) = 4d8250dd3623abff518e5cbc19946ee1
-SHA256 (vitunes-1.0.1.tgz) = 31d27da83a25c8084db03d3ae9917ea17cde5ba430645dd2cd898e79788ac8c8
-SIZE (vitunes-1.0.1.tgz) = 54274
+MD5 (vitunes-1.0.2.tgz) = 0a76e955938ab3879ffe929a2eec5820
+SHA256 (vitunes-1.0.2.tgz) = 80427ad0e87391f0208a5a7840fe5b0e5f17d21a97098b257a80970c678badf2
+SIZE (vitunes-1.0.2.tgz) = 55143
diff --git a/audio/vitunes/files/patch-Makefile b/audio/vitunes/files/patch-Makefile
deleted file mode 100644
index e0b3b550ecad..000000000000
--- a/audio/vitunes/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Makefile.orig 2010-01-04 03:17:55.000000000 +0100
-+++ ./Makefile 2010-01-05 18:32:48.000000000 +0100
-@@ -7,7 +7,7 @@
- LDEPS=-L/usr/local/lib -lid3tag -lmp4v2 -logg -lvorbis -lvorbisfile
-
- CC=/usr/bin/gcc
--CFLAGS=-c -Wall -ansi -g $(CDEPS)
-+CFLAGS=-c -Wall -g $(CDEPS) -std=c99
- LDFLAGS=-lutil -lncurses -lm $(LDEPS)
-
-
diff --git a/audio/vitunes/files/patch-medialib.h b/audio/vitunes/files/patch-medialib.h
deleted file mode 100644
index 17f4d72db14a..000000000000
--- a/audio/vitunes/files/patch-medialib.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./medialib.h.orig 2010-01-04 03:17:55.000000000 +0100
-+++ ./medialib.h 2010-01-05 18:32:57.000000000 +0100
-@@ -7,9 +7,15 @@
- #ifndef MEDIA_LIBRARY_H
- #define MEDIA_LIBRARY_H
-
-+#include <limits.h>
-+#include <stdlib.h>
- #include <sys/errno.h>
- #include <sys/types.h>
- #include <sys/stat.h>
-+#include <unistd.h>
-+
-+typedef unsigned short u_short;
-+
- #include <fts.h>
-
- #include "meta_info.h"
diff --git a/audio/vitunes/files/patch-uinterface.h b/audio/vitunes/files/patch-uinterface.h
index 783d39fae154..ffafd4383ec1 100644
--- a/audio/vitunes/files/patch-uinterface.h
+++ b/audio/vitunes/files/patch-uinterface.h
@@ -1,6 +1,6 @@
---- ./uinterface.h.orig 2010-01-04 03:17:55.000000000 +0100
-+++ ./uinterface.h 2010-01-05 18:33:14.000000000 +0100
-@@ -17,11 +17,11 @@
+--- ./uinterface.h.orig 2010-01-14 18:24:04.000000000 +0100
++++ ./uinterface.h 2010-01-14 18:24:15.000000000 +0100
+@@ -17,7 +17,6 @@
#define UINTERFACE_H
#include <sys/ioctl.h>
@@ -8,8 +8,3 @@
#include <ncurses.h>
#include <ctype.h>
#include <stdio.h>
- #include <stdlib.h>
-+#include <stdint.h>
- #include <string.h>
- #include <stdbool.h>
- #include <termios.h>
diff --git a/audio/vitunes/files/patch-vitunes.h b/audio/vitunes/files/patch-vitunes.h
index b5c34c9ffddd..38d2414f26f1 100644
--- a/audio/vitunes/files/patch-vitunes.h
+++ b/audio/vitunes/files/patch-vitunes.h
@@ -1,17 +1,10 @@
---- ./vitunes.h.orig 2010-01-04 03:17:55.000000000 +0100
-+++ ./vitunes.h 2010-01-05 18:33:18.000000000 +0100
-@@ -1,10 +1,13 @@
- #ifndef VITUNES_H
- #define VITUNES_H
-
-+#include <signal.h>
- #include <sys/time.h>
- #include <locale.h>
+--- ./vitunes.h.orig 2010-01-14 18:28:36.000000000 +0100
++++ ./vitunes.h 2010-01-14 18:28:43.000000000 +0100
+@@ -6,7 +6,6 @@
+ #include <getopt.h>
+ #include <signal.h>
+ #include <unistd.h>
-#include <util.h>
-+//#include <util.h>
#include <pwd.h>
-+#include <unistd.h>
-+#include <getopt.h>
#include "input_handlers.h"
- #include "uinterface.h"