aboutsummaryrefslogtreecommitdiff
path: root/audio/wavbreaker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/wavbreaker/Makefile')
-rw-r--r--audio/wavbreaker/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/audio/wavbreaker/Makefile b/audio/wavbreaker/Makefile
index dcce1713b8a4..f74ea805ecd4 100644
--- a/audio/wavbreaker/Makefile
+++ b/audio/wavbreaker/Makefile
@@ -10,11 +10,12 @@ MASTER_SITES= SF
MAINTAINER= gahr@FreeBSD.org
COMMENT= Tool to split and merge wav files
+LICENSE= GPLv2
+
OPTIONS_DEFINE= PULSEAUDIO NLS
USE_GNOME= gtk20 libxml2
-NO_STAGE= yes
-USES= gmake pathfix pkgconfig
+USES= gmake pathfix pkgconfig desktop-file-utils
GNU_CONFIGURE= yes
CONFIGURE_ENV= PKG_CONFIG="${LOCALBASE}/bin/pkg-config"
CPPFLAGS+= -I${LOCALBASE}/include
@@ -22,21 +23,19 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-alsa
INSTALLS_ICONS= yes
-MAN1= wavbreaker.1 wavinfo.1 wavmerge.1
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPULSEAUDIO}
LIB_DEPENDS+= libpulse.so:${PORTSDIR}/audio/pulseaudio
.else
-CONFIGURE_ARGS+= --disable-pulse
+CONFIGURE_ARGS+=--disable-pulse
.endif
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB= NLS=""
.else
-CONFIGURE_ARGS+= --disable-nls
+CONFIGURE_ARGS+=--disable-nls
PLIST_SUB= NLS="@comment "
.endif