aboutsummaryrefslogtreecommitdiff
path: root/audio/whysynth/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/whysynth/Makefile')
-rw-r--r--audio/whysynth/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/audio/whysynth/Makefile b/audio/whysynth/Makefile
new file mode 100644
index 000000000000..c24fcb9ea13a
--- /dev/null
+++ b/audio/whysynth/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: whysynth
+# Date created: 2007-01-20
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= whysynth
+PORTVERSION= 20060122
+CATEGORIES= audio
+MASTER_SITES= http://home.jps.net/~musound/
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Versatile softsynth implemented as a DSSI plugin
+
+LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
+ lo.6:${PORTSDIR}/audio/liblo \
+ jack.0:${PORTSDIR}/audio/jack \
+ fftw3f.4:${PORTSDIR}/math/fftw3-float
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+.include <bsd.port.mk>