aboutsummaryrefslogtreecommitdiff
path: root/audio/wmtune
diff options
context:
space:
mode:
Diffstat (limited to 'audio/wmtune')
-rw-r--r--audio/wmtune/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/audio/wmtune/Makefile b/audio/wmtune/Makefile
index 6b1f83ba7a3c..906fdc8773f2 100644
--- a/audio/wmtune/Makefile
+++ b/audio/wmtune/Makefile
@@ -26,10 +26,12 @@ USE_REINPLACE= yes
PATCH_ARGS =-p0 -d ${WRKDIR}
+ONLY_FOR_ARCHS= i386 alpha
+
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386" && !(${ARCH} == "alpha" && ${OSVERSION} >= 500000)
-BROKEN= "Does not compile on !i386 or alpha 4.x"
+.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
+IGNORE= "cannot be build on alpha 4.x, which does not have bktr hardware support"
.endif
.if !defined(WITH_RADIOTRACK)