aboutsummaryrefslogtreecommitdiff
path: root/audio/wmtune
diff options
context:
space:
mode:
Diffstat (limited to 'audio/wmtune')
-rw-r--r--audio/wmtune/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/audio/wmtune/Makefile b/audio/wmtune/Makefile
index f8b303cbdb48..f82cff458d53 100644
--- a/audio/wmtune/Makefile
+++ b/audio/wmtune/Makefile
@@ -40,6 +40,9 @@ WMTUNE_DIFF= wmtune.radiotrack.diff.gz
post-patch:
@${GUNZIP_CMD} -c ${DISTDIR}/${WMTUNE_DIFF} | ${PATCH} ${PATCH_ARGS}
+ @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig
+ @${SED} -e 's|-O2|${CFLAGS}|' -e 's|cc|${CC}|' \
+ < ${WRKSRC}/Makefile.orig > ${WRKSRC}/Makefile
do-configure:
@${PERL} -pi.orig -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/src/wmtune.c