aboutsummaryrefslogtreecommitdiff
path: root/audio/x11amp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/x11amp/Makefile')
-rw-r--r--audio/x11amp/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/x11amp/Makefile b/audio/x11amp/Makefile
new file mode 100644
index 000000000000..f92e1a43d2c3
--- /dev/null
+++ b/audio/x11amp/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: x11amp
+# Date created: 13 Jul 1998
+# Whom: Donald Burr <dburr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= x11amp
+PORTVERSION= 0.9.b1.1
+PORTREVISION= 7
+CATEGORIES= audio
+MASTER_SITES= LOCAL
+MASTER_SITE_SUBDIR= hrs
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/-beta/}
+
+MAINTAINER= turutani@scphys.kyoto-u.ac.jp
+COMMENT= X11-based MP3 player with nice graphical interface
+
+USE_GNOME= gtk12 esound
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+CONFIGURE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+post-extract:
+ @${CP} ${FILESDIR}/main.xpm ${WRKSRC}/x11amp/defskin
+ @${CHMOD} a+x ${WRKSRC}/ltconfig
+
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/ltconfig
+
+.include <bsd.port.mk>