aboutsummaryrefslogtreecommitdiff
path: root/audio/xmcd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/xmcd/Makefile')
-rw-r--r--audio/xmcd/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/audio/xmcd/Makefile b/audio/xmcd/Makefile
index f5ca7103700d..155132039a15 100644
--- a/audio/xmcd/Makefile
+++ b/audio/xmcd/Makefile
@@ -7,17 +7,23 @@
PORTNAME= xmcd
PORTVERSION= 2.6
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://metalab.unc.edu/tkan/download/xmcd/src/
MAINTAINER= eischen@vigrid.com
+.if defined(XFREE86_VERSION) && ${XFREE86_VERSION} == 4
+BUILD_DEPENDS= ${RMAN}:${PORTSDIR}/x11/XFree86-4-clients
+.endif
+
USE_MOTIF= yes
USE_IMAKE= yes
PLIST_SUB+= RELEASE=${OSREL:R} ARCH=${ARCH}
MAN1= cda.1 cddbcmd.1 dp2xmcd.1 wm2xmcd.1 xmcd.1
MANCOMPRESSED= no
+RMAN= ${X11BASE}/bin/rman
post-extract:
@${CHMOD} -R u+w ${WRKSRC}
@@ -29,8 +35,29 @@ post-patch:
@${SED} -e "s;@PREFIX@;${PREFIX};g" ${WRKSRC}/xmcd_d/XMcd.ad.in \
> ${WRKSRC}/xmcd_d/XMcd.ad
+.if defined(XFREE86_VERSION) && ${XFREE86_VERSION} == 4
+post-build:
+ (cd ${WRKSRC}; \
+ for i in xmcd cda; do \
+ ${RM} -f $${i}-1.html; \
+ ${RMAN} -f HTML < $${i}_d/$${i}.man > $${i}-1.html && \
+ ${MV} $${i}-1.html $${i}.1.html; \
+ done; \
+ for i in cddbcmd dp2xmcd wm2xmcd; do \
+ ${RM} -f $${i}-1.html; \
+ ${RMAN} -f HTML < util_d/$${i}.man > $${i}-1.html && \
+ ${MV} $${i}-1.html $${i}.1.html; \
+ done)
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
@${CP} ${WRKSRC}/xmcd_d/XMcd.ad ${PREFIX}/lib/X11/app-defaults/XMcd
+.if defined(XFREE86_VERSION) && ${XFREE86_VERSION} == 4
+ (cd ${WRKSRC}; \
+ for i in xmcd cda cddbcmd dp2xmcd wm2xmcd; do \
+ ${INSTALL_MAN} $${i}.1.html ${PREFIX}/lib/X11/doc/html; \
+ done)
+.endif
.include <bsd.port.mk>