aboutsummaryrefslogtreecommitdiff
path: root/audio/xmcd
diff options
context:
space:
mode:
Diffstat (limited to 'audio/xmcd')
-rw-r--r--audio/xmcd/distinfo2
-rw-r--r--audio/xmcd/files/patch-af39
2 files changed, 1 insertions, 40 deletions
diff --git a/audio/xmcd/distinfo b/audio/xmcd/distinfo
index e2bd834f5d59..67b12710d943 100644
--- a/audio/xmcd/distinfo
+++ b/audio/xmcd/distinfo
@@ -1 +1 @@
-MD5 (xmcd-2.5.tar.gz) = de8d66770be5acc492e0c7c3ff03e0a0
+MD5 (xmcd-2.5.tar.gz) = 316dd535081bc714c0745217471cfd65
diff --git a/audio/xmcd/files/patch-af b/audio/xmcd/files/patch-af
deleted file mode 100644
index 5200c47286f0..000000000000
--- a/audio/xmcd/files/patch-af
+++ /dev/null
@@ -1,39 +0,0 @@
---- xmcd_d/main.c.orig Sat Apr 24 03:41:00 1999
-+++ xmcd_d/main.c Sun May 23 11:55:01 1999
-@@ -151,6 +151,8 @@
- {
- int i;
- Display *display;
-+ uid_t euid, ruid;
-+ gid_t egid, rgid;
-
- /* Error message stream */
- errfp = stderr;
-@@ -201,6 +203,16 @@
- }
- }
-
-+ /* get real IDs */
-+ ruid = getuid();
-+ rgid = getgid();
-+ /* save effective IDs */
-+ euid = geteuid();
-+ egid = getegid();
-+ /* give up root until we have a connection to the X server */
-+ (void)seteuid(ruid);
-+ (void)setegid(rgid);
-+
- /* Initialize X toolkit */
- widgets.toplevel = XtVaAppInitialize(
- &app_context,
-@@ -210,6 +222,10 @@
- NULL,
- NULL
- );
-+
-+ /* Ok, back to root */
-+ (void)seteuid(euid);
-+ (void)setegid(egid);
-
- /* Get application options */
- XtVaGetApplicationResources(