aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-flac/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/xmms-flac/Makefile')
-rw-r--r--audio/xmms-flac/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
index 1c5145c9828d..f3b2b44057aa 100644
--- a/audio/xmms-flac/Makefile
+++ b/audio/xmms-flac/Makefile
@@ -6,23 +6,20 @@
#
PORTNAME= xmms-flac
-PORTVERSION= 1.1.2
-PORTREVISION= 4
+PORTVERSION= 1.2.1
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:sf/} \
- ${MASTER_SITE_LOCAL:S/$/:local/}
-MASTER_SITE_SUBDIR= flac/:sf naddy/:local
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= flac
DISTNAME= flac-${PORTVERSION}
-DISTFILES= ${EXTRACT_ONLY}:sf flac-alloc.h:local
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= naddy@FreeBSD.org
COMMENT= XMMS input plugin for playing FLAC files
LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
- FLAC.7:${PORTSDIR}/audio/flac
+ FLAC.10:${PORTSDIR}/audio/flac
USE_AUTOTOOLS= libtool:15
+CONFIGURE_TARGET= --target=${ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}" \
--with-xmms-prefix="${X11BASE}"
@@ -30,9 +27,6 @@ MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=disable-static"
MAKE_ENV= MAKEOBJDIR=/nonexistent # ignore ${WRKSRC}/obj
MAKEFILE= ${FILESDIR}/Makefile
-post-extract:
- @${CP} ${DISTDIR}/flac-alloc.h ${WRKSRC}/include/share/alloc.h
-
# XXX
post-install:
${RM} ${PREFIX}/lib/xmms/Input/libxmms-flac.la