aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-sexyspc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/xmms-sexyspc/Makefile')
-rw-r--r--audio/xmms-sexyspc/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/xmms-sexyspc/Makefile b/audio/xmms-sexyspc/Makefile
new file mode 100644
index 000000000000..75be19d4ca1d
--- /dev/null
+++ b/audio/xmms-sexyspc/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xmms-sexyspc
+# Date created: 5 August 2007
+# Whom: Naram Qashat <cyberbotx@cyberbotx.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sexyspc
+PORTVERSION= 0.5.0
+CATEGORIES= audio
+MASTER_SITES= SF
+PKGNAMEPREFIX= xmms-
+
+MAINTAINER= cyberbotx@cyberbotx.com
+COMMENT= An SPC plugin for XMMS based on the SNESAPU emulation core
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm \
+ xmms:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+
+PLIST_FILES= lib/xmms/Input/libsexyspc.a \
+ lib/xmms/Input/libsexyspc.la \
+ lib/xmms/Input/libsexyspc.so
+
+ONLY_FOR_ARCHS= i386 # contains x86 assembler code
+USE_XLIB= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>