aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-xf86audio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/xmms-xf86audio/Makefile')
-rw-r--r--audio/xmms-xf86audio/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/xmms-xf86audio/Makefile b/audio/xmms-xf86audio/Makefile
new file mode 100644
index 000000000000..60a310dfd348
--- /dev/null
+++ b/audio/xmms-xf86audio/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xmms-xf86audio
+# Date created: 2005-06-16
+# Whom: Christian Weisgerber <naddy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-xf86audio
+PORTVERSION= 0.4.3
+CATEGORIES= audio
+MASTER_SITES= http://www.devin.com/xmms-xf86audio/download/
+
+MAINTAINER= naddy@FreeBSD.org
+COMMENT= XF86Audio multimedia-key support for XMMS
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+
+USE_X_PREFIX= yes
+MAKE_ARGS= CC="${CC}" OPT="${CFLAGS}" DEBUG=""
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libxf86audio.so \
+ `xmms-config --general-plugin-dir`
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>