aboutsummaryrefslogtreecommitdiff
path: root/audio/yamt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/yamt/Makefile')
-rw-r--r--audio/yamt/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/audio/yamt/Makefile b/audio/yamt/Makefile
index 70a9de10571d..78016794600d 100644
--- a/audio/yamt/Makefile
+++ b/audio/yamt/Makefile
@@ -16,18 +16,17 @@ MAINTAINER= demon@FreeBSD.org
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs gnomehack gnomeprefix
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
- s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
.include <bsd.port.mk>