aboutsummaryrefslogtreecommitdiff
path: root/audio/zynaddsubfx
diff options
context:
space:
mode:
Diffstat (limited to 'audio/zynaddsubfx')
-rw-r--r--audio/zynaddsubfx/Makefile17
-rw-r--r--audio/zynaddsubfx/files/patch-Output-JACKaudiooutput.C15
2 files changed, 19 insertions, 13 deletions
diff --git a/audio/zynaddsubfx/Makefile b/audio/zynaddsubfx/Makefile
index 4002833ea5b5..ad451ad5c880 100644
--- a/audio/zynaddsubfx/Makefile
+++ b/audio/zynaddsubfx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zynaddsubfx
PORTVERSION= 2.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= zynaddsubfx
@@ -25,7 +25,12 @@ LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
fltk.1:${PORTSDIR}/x11-toolkits/fltk \
expat.6:${PORTSDIR}/textproc/expat2 \
jack.0:${PORTSDIR}/audio/jack
-BUILD_DEPENDS= ${LOCALBASE}/include/mxml.h:${PORTSDIR}/textproc/mini-xml
+BUILD_DEPENDS= ${LOCALBASE}/include/mxml.h:${PORTSDIR}/textproc/mini-xml \
+ jackit>=0.109.2:${PORTSDIR}/audio/jack
+
+# Between 0.109.0 and earlier versions there was an api change in JACK.
+# However, the library version number was not changed. The line above
+# is supposed to work around that.
WRKSRC= ${WRKDIR}/${DISTNAME}/src
@@ -45,10 +50,4 @@ do-install:
cd ${WRKDIR}/${DISTNAME}/presets && ${FIND} . -type f \
-exec ${INSTALL_DATA} {} ${DATADIR}/presets/{} \;
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-BROKEN= Does not compile on 4.x and 5.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/zynaddsubfx/files/patch-Output-JACKaudiooutput.C b/audio/zynaddsubfx/files/patch-Output-JACKaudiooutput.C
index 44c7e9fe1cf1..2ebe01652928 100644
--- a/audio/zynaddsubfx/files/patch-Output-JACKaudiooutput.C
+++ b/audio/zynaddsubfx/files/patch-Output-JACKaudiooutput.C
@@ -1,5 +1,5 @@
---- Output/JACKaudiooutput.C.orig Sun Jan 28 01:26:00 2007
-+++ Output/JACKaudiooutput.C Sun Jan 28 01:28:35 2007
+--- Output/JACKaudiooutput.C.orig 2008-07-23 14:05:40.000000000 +0200
++++ Output/JACKaudiooutput.C 2008-07-23 14:06:33.000000000 +0200
@@ -38,6 +38,7 @@
jackmaster=master_;
jackclient=0;
@@ -24,12 +24,19 @@
return(true);
};
-@@ -114,7 +124,7 @@
+@@ -114,13 +124,13 @@
jack_midi_event_t jack_midi_event;
jack_nframes_t event_index = 0;
jack_nframes_t event_count =
- jack_midi_port_get_info(midi_buf, frames)->event_count;
-+ jack_midi_get_event_count(midi_buf, frames);
++ jack_midi_get_event_count(midi_buf);
unsigned char* midi_data;
unsigned char type, chan;
+ while (event_index < event_count) {
+
+- jack_midi_event_get(&jack_midi_event, midi_buf, event_index, frames);
++ jack_midi_event_get(&jack_midi_event, midi_buf, event_index);
+ midi_data = jack_midi_event.buffer;
+ type = midi_data[0] & 0xF0;
+ chan = midi_data[0] & 0x0F;