aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/baudline/Makefile2
-rw-r--r--audio/csound/Makefile2
-rw-r--r--audio/firefly/Makefile2
-rw-r--r--audio/ncmpcpp/Makefile2
-rw-r--r--audio/tuxguitar/Makefile2
5 files changed, 6 insertions, 4 deletions
diff --git a/audio/baudline/Makefile b/audio/baudline/Makefile
index 67932e0244b8..e43f75d09a66 100644
--- a/audio/baudline/Makefile
+++ b/audio/baudline/Makefile
@@ -23,7 +23,7 @@ RESTRICTED= author requests no distribution except from their site
PORTDOCS= README_unix.txt
PLIST_FILES= bin/baudline
-OPTIONS_DEFINE= MPG123
+OPTIONS_DEFINE= MPG123 DOCS
OPTIONS_DEFAULT= MPG123
MMPG123_RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index c90832d4af6d..fd20a0fe8c60 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
PORTSCOUT= limit:^5\.
-OPTIONS_DEFINE= ALSA DSSI FLTK FLUIDSYNTH JACK OSC PORTAUDIO PULSEAUDIO
+OPTIONS_DEFINE= ALSA DSSI FLTK FLUIDSYNTH JACK OSC PORTAUDIO PULSEAUDIO DOCS
OPTIONS_DEFAULT=FLTK
OPTIONS_SUB= yes
ALSA_DESC= Build ALSA I/O module
diff --git a/audio/firefly/Makefile b/audio/firefly/Makefile
index 26495fe7f887..b9d5fa81a00b 100644
--- a/audio/firefly/Makefile
+++ b/audio/firefly/Makefile
@@ -46,7 +46,7 @@ USE_LDCONFIG= yes
USE_GCC= any
-OPTIONS_DEFINE= JAPANESE
+OPTIONS_DEFINE= JAPANESE DOCS
JAPANESE_DESC= Japanese support in ID3 tags
.include <bsd.port.options.mk>
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index 03c169700585..884b4d58db5d 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -24,7 +24,7 @@ ACLOCAL_ARGS= --automake-acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-OPTIONS_DEFINE= CURL CLOCK UTF8 TAGLIB OUTPUTS VISUALIZER
+OPTIONS_DEFINE= CURL CLOCK UTF8 TAGLIB OUTPUTS VISUALIZER DOCS
OPTIONS_DEFAULT= CURL CLOCK OUTPUTS VISUALIZER
CURL_DESC= Enable fetching lyrics from the Internet
CLOCK_DESC= clock-screen support
diff --git a/audio/tuxguitar/Makefile b/audio/tuxguitar/Makefile
index bd8f75d6e1a1..771c8a9ee4fd 100644
--- a/audio/tuxguitar/Makefile
+++ b/audio/tuxguitar/Makefile
@@ -38,6 +38,8 @@ NOCCACHE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}/TuxGuitar
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
PLUGINS= ascii browser-ftp compat converter fluidsynth gervill gtp \
jsa lilypond midi musicxml oss pdf ptb tef tray tuner