aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/beast/Makefile26
-rw-r--r--audio/beast/pkg-plist5
2 files changed, 16 insertions, 15 deletions
diff --git a/audio/beast/Makefile b/audio/beast/Makefile
index c1cdd8622534..bca1918e0bb2 100644
--- a/audio/beast/Makefile
+++ b/audio/beast/Makefile
@@ -13,20 +13,18 @@ COMMENT= Powerful music composition and modular synthesis application
LICENSE= LGPL21
-LIB_DEPENDS= asound:${PORTSDIR}/audio/alsa-lib \
- mad:${PORTSDIR}/audio/libmad \
- vorbisfile:${PORTSDIR}/audio/libvorbis \
- guile:${PORTSDIR}/lang/guile
+LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib \
+ libmad.so:${PORTSDIR}/audio/libmad \
+ libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
+ libguile.so:${PORTSDIR}/lang/guile
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
-BROKEN= Does not build
-
+OPTIONS_DEFINE= DEBUG
OPTIONS_DEFINE_i386= SSE
USE_BZIP2= yes
-NO_STAGE= yes
-USES= gmake pathfix gettext pkgconfig
-USE_GCC= yes
+USES= desktop-file-utils gmake gettext pathfix pkgconfig shared-mime-info
+USE_GCC= 4.6+
USE_GNOME= gnomehier libgnomecanvas
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules \
@@ -40,8 +38,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VERSION="${PORTVERSION}"
-MAN1= beast.1 bsescm.1 bsewavetool.1 sfidl.1
-MAN5= bse.5
+DEBUG_CONFIGURE_ENABLE= debug
.include <bsd.port.pre.mk>
@@ -57,10 +54,6 @@ PLIST_SUB+= SSE="@comment "
SSE_FLAGS= # none
.endif
-.if empty(PORT_OPTIONS:MDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
'/^[[:space:]].*FLAGS -[Ofgp].*"/s|^|#| ; \
@@ -75,5 +68,8 @@ post-patch:
@${REINPLACE_CMD} -e \
's|; q|;| ; \
s|-o \(pipefail\)|\1|' ${WRKSRC}/docs/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|-DG_DISABLE_DEPRECATED||' ${WRKSRC}/bse/Makefile.am \
+ ${WRKSRC}/bse/Makefile.in
.include <bsd.port.post.mk>
diff --git a/audio/beast/pkg-plist b/audio/beast/pkg-plist
index 3a738d498219..6811e21ae834 100644
--- a/audio/beast/pkg-plist
+++ b/audio/beast/pkg-plist
@@ -4,6 +4,11 @@ bin/bsescm
bin/bsescm-%%VERSION%%
bin/bsewavetool
bin/sfidl
+man/man1/beast.1.gz
+man/man1/bsescm.1.gz
+man/man1/bsewavetool.1.gz
+man/man1/sfidl.1.gz
+man/man5/bse.5.gz
include/birnet/birnet.hh
include/birnet/birnetcdefs.h
include/birnet/birnetconfig.h