aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/fcplay/Makefile8
-rw-r--r--audio/opmixer/Makefile8
-rw-r--r--audio/rebler/Makefile8
-rw-r--r--audio/spiralloops/Makefile8
-rw-r--r--audio/spiralsynth/Makefile8
5 files changed, 35 insertions, 5 deletions
diff --git a/audio/fcplay/Makefile b/audio/fcplay/Makefile
index ceb2d8ce8213..92f89b43dbce 100644
--- a/audio/fcplay/Makefile
+++ b/audio/fcplay/Makefile
@@ -18,6 +18,12 @@ COMMENT= Future Composer Reference Player
BUILD_DEPENDS= ${LOCALBASE}/include/sidplay/compconf.h:${PORTSDIR}/audio/libsidplay
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
@@ -32,4 +38,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/POINTER ${PREFIX}/share/doc/fcplay
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/opmixer/Makefile b/audio/opmixer/Makefile
index 910709f6d1f4..c261b62a4af6 100644
--- a/audio/opmixer/Makefile
+++ b/audio/opmixer/Makefile
@@ -18,6 +18,12 @@ COMMENT= Adjusts a mixer
LIB_DEPENDS= gtkmm.2:${PORTSDIR}/x11-toolkits/gtk-- \
intl.4:${PORTSDIR}/devel/gettext
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
DOCDIR= share/doc/${PORTNAME}
USE_BZIP2= yes
USE_X_PREFIX= yes
@@ -41,4 +47,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/${DOCDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/rebler/Makefile b/audio/rebler/Makefile
index 83c19610b6f4..f8fb6cd2541c 100644
--- a/audio/rebler/Makefile
+++ b/audio/rebler/Makefile
@@ -19,6 +19,12 @@ LIB_DEPENDS= mpeg2:${PORTSDIR}/multimedia/libmpeg2 \
aviplay.0:${PORTSDIR}/multimedia/avifile \
popt:${PORTSDIR}/devel/popt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_BZIP2= yes
AVIFILE_CONFIG?= ${LOCALBASE}/bin/avifile-config
CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
@@ -33,4 +39,4 @@ do-build:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/rebler ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/spiralloops/Makefile b/audio/spiralloops/Makefile
index b854fc918ccf..4281e4f02af5 100644
--- a/audio/spiralloops/Makefile
+++ b/audio/spiralloops/Makefile
@@ -16,6 +16,12 @@ COMMENT= Loop-based sampler
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
DOCDIR= share/doc/${PORTNAME}
DOC_FILES= CHANGES COPYING README
GNU_CONFIGURE= yes
@@ -50,4 +56,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index 9c808e3420b8..3a14db670757 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -16,6 +16,12 @@ COMMENT= MIDI-capable synthesizer for X
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
GNU_CONFIGURE= yes
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
@@ -69,4 +75,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>