aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/ardour/Makefile5
-rw-r--r--audio/ifp-line/Makefile16
-rw-r--r--audio/libmtp/Makefile10
-rw-r--r--audio/libnjb/Makefile6
-rw-r--r--audio/mpiosh/Makefile18
-rw-r--r--audio/mpiosh/files/extra-patch-configure.in41
-rw-r--r--audio/rioutil/Makefile15
-rw-r--r--audio/rioutil/files/extra-patch-configure.ac17
8 files changed, 112 insertions, 16 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index 0a691b1137ba..6bef2ebdf17a 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -25,7 +25,6 @@ LIB_DEPENDS= lrdf.2:${PORTSDIR}/textproc/liblrdf \
sqlite3:${PORTSDIR}/databases/sqlite3 \
lo.6:${PORTSDIR}/audio/liblo \
SoundTouch.0:${PORTSDIR}/audio/soundtouch \
- usb:${PORTSDIR}/devel/libusb \
fftw3f:${PORTSDIR}/math/fftw3-float \
fftw3:${PORTSDIR}/math/fftw3 \
aubio.3:${PORTSDIR}/audio/aubio
@@ -53,6 +52,10 @@ OPTIONS= OPTIMIZED_CFLAGS "Builds with compiler optimizations" on \
BROKEN= needs posix_memalign()
.endif
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.endif
+
.if defined(WITH_VST)
# Yes, 'PlugIns' is not a typo.
VST_DIST+= vst_sdk2_3.zip
diff --git a/audio/ifp-line/Makefile b/audio/ifp-line/Makefile
index f1a95a8a4460..c08ce5d28dc5 100644
--- a/audio/ifp-line/Makefile
+++ b/audio/ifp-line/Makefile
@@ -15,13 +15,23 @@ MASTER_SITE_SUBDIR= ifp-driver
MAINTAINER= riggs@rrr.de
COMMENT= Command line interface to iRiver music players
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-
MAN1= ifp.1
PLIST_FILES+= bin/ifp
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
+post-patch:
+.if ${OSVERSION} >= 800069
+ @${REINPLACE_CMD} -E -e 's,`libusb-config --cflags`,,g' \
+ -e 's,`libusb-config --libs`,-lusb,g' ${WRKSRC}/Makefile
+.endif
+
post-install:
@${CAT} ${.CURDIR}/pkg-message
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/libmtp/Makefile b/audio/libmtp/Makefile
index fdd2c69be81b..8636bb2b16ff 100644
--- a/audio/libmtp/Makefile
+++ b/audio/libmtp/Makefile
@@ -15,8 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= pesho.petrov@gmail.com
COMMENT= Media Transfer Protocol (MTP) library
-LIB_DEPENDS= usb:${PORTSDIR}/devel/libusb \
- iconv:${PORTSDIR}/converters/libiconv
+LIB_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
@@ -26,7 +25,12 @@ USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib -liconv
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|doc||' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/libnjb/Makefile b/audio/libnjb/Makefile
index 6ae6d5a912b1..8b158fad8af8 100644
--- a/audio/libnjb/Makefile
+++ b/audio/libnjb/Makefile
@@ -14,8 +14,6 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= C library, API for communicating with Creative and Dell audio players
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -24,6 +22,10 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/audio/mpiosh/Makefile b/audio/mpiosh/Makefile
index 0c51baec17bc..8d62ba3a0585 100644
--- a/audio/mpiosh/Makefile
+++ b/audio/mpiosh/Makefile
@@ -14,8 +14,6 @@ DISTNAME= mpio-${PORTVERSION:S|.p|_pre|}
MAINTAINER= ports@FreeBSD.org
COMMENT= Digit@lway MPIO MP3 player tool
-LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
-
USE_AUTOTOOLS= libtool:15
USE_ICONV= yes
GNU_CONFIGURE= yes
@@ -23,4 +21,18 @@ USE_LDCONFIG= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.in
+USE_AUTOTOOLS= autoconf:262
+.endif
+
+post-patch:
+.if ${OSVERSION} >= 800069
+ ${RM} -f ${WRKSRC}/configure
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/mpiosh/files/extra-patch-configure.in b/audio/mpiosh/files/extra-patch-configure.in
new file mode 100644
index 000000000000..22deee13d378
--- /dev/null
+++ b/audio/mpiosh/files/extra-patch-configure.in
@@ -0,0 +1,41 @@
+--- configure.in.orig 2004-05-30 05:45:55.000000000 +0400
++++ configure.in 2009-03-07 01:43:55.000000000 +0300
+@@ -60,34 +60,18 @@
+ dnl -- check for libusb
+ dnl -- this is stolen from libgphoto2
+
+-AC_PATH_PROG(LIBUSB_CONFIG,libusb-config)
+-if test -n "${LIBUSB_CONFIG}"; then
+- CPPFLAGS_save="$CPPFLAGS"
+- CPPFLAGS="$CPPFLAGS `$LIBUSB_CONFIG --cflags`"
++CPPFLAGS_save="$CPPFLAGS"
+ AC_CHECK_HEADER(usb.h,[
+ LDFLAGS_orig="$LDFLAGS"
+- LDFLAGS="`$LIBUSB_CONFIG --libs`"
++ LDFLAGS="-lusb"
+ AC_CHECK_LIB(usb,usb_busses,[
+ usb_msg="yes"
+ IOLIB_SUBDIRS="$IOLIB_SUBDIRS usb"
+- USB_LIBS="`$LIBUSB_CONFIG --libs`"
+- USB_CFLAGS="`$LIBUSB_CONFIG --cflags`"
+- LIBUSB_VER="`$LIBUSB_CONFIG --version`"],[
++ USB_LIBS="-lusb"
++ USB_CFLAGS=""],[
+ usb_msg="no (available version too old)"])
+ LDFLAGS="$LDFLAGS_orig"])
+ CPPFLAGS="$CPPFLAGS_save"
+-fi
+-
+- # This 'test' call uses non-standard syntax and will fail on most
+- # systems, but it's just informational so any warning can be ignored.
+-if test "$LIBUSB_VER" \< "0.1.7"; then
+- AC_MSG_WARN([
+-*** You need at least version 0.1.7 of the libusb library for USB support
+-*** http://sourceforge.net/projects/libusb/
+-*** If you cannot find the appropriate version, try CVS
+- ])
+- exit 1
+-fi
+
+ case "$usb_msg" in
+ yes*) AC_DEFINE(HAVE_USB,1,[Whether you have USB support enabled]);;
diff --git a/audio/rioutil/Makefile b/audio/rioutil/Makefile
index 1ad61d795220..f2ae6eef104f 100644
--- a/audio/rioutil/Makefile
+++ b/audio/rioutil/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A program to inferface with the Rio600, Rio800, and psa[play devices
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -26,10 +24,19 @@ MAN1= rioutil.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.ac
+USE_AUTOTOOLS= autoconf:262
+.endif
+
post-extract:
- @${RM} -f ${WRKSRC}/src/getopt*
+# @${RM} -f ${WRKSRC}/src/getopt*
# Fix for GCC 4.2
@${REINPLACE_CMD} -e 's,read_buffer = .*),(&),' \
${WRKSRC}/librioutil/rio.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/rioutil/files/extra-patch-configure.ac b/audio/rioutil/files/extra-patch-configure.ac
new file mode 100644
index 000000000000..34d3d9d06a68
--- /dev/null
+++ b/audio/rioutil/files/extra-patch-configure.ac
@@ -0,0 +1,17 @@
+--- configure.ac.orig 2009-03-07 01:48:24.000000000 +0300
++++ configure.ac 2009-03-07 01:49:07.000000000 +0300
+@@ -74,13 +74,7 @@
+ AC_MSG_RESULT(yes)
+ AC_DEFINE_UNQUOTED(WITH_LIBUSB)
+
+- AC_PATH_PROG(LIBUSB_CONFIG,libusb-config)
+- if test -n "${LIBUSB_CONFIG}"; then
+- CFLAGS="`${LIBUSB_CONFIG} --cflags` $CFLAGS"
+- LIBS="`${LIBUSB_CONFIG} --libs` $LIBS"
+- else
+- AC_MSG_ERROR(Can't find libusb)
+- fi
++ LIBS="-lusb $LIBS"
+
+ AC_CHECK_LIB(usb, usb_open)
+ AC_SUBST(WITH_LIBUSB)