aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/ampache/Makefile2
-rw-r--r--audio/autocd/Makefile2
-rw-r--r--audio/cmp3/Makefile2
-rw-r--r--audio/cutmp3/Makefile2
-rw-r--r--audio/cymbaline/Makefile2
-rw-r--r--audio/dvda-author/Makefile2
-rw-r--r--audio/enscribe/Makefile2
-rw-r--r--audio/festival-freebsoft-utils/Makefile2
-rw-r--r--audio/funktrackergold/Makefile2
-rw-r--r--audio/id3mtag/Makefile2
-rw-r--r--audio/libmpdclient/Makefile2
-rw-r--r--audio/linux-neroaaccodec/Makefile2
-rw-r--r--audio/listener/Makefile2
-rw-r--r--audio/maplay/Makefile2
-rw-r--r--audio/mp3asm/Makefile2
-rw-r--r--audio/mp3c/Makefile2
-rw-r--r--audio/pure-audio/Makefile2
-rw-r--r--audio/py-eyed3/Makefile2
-rw-r--r--audio/py-openal/Makefile2
-rw-r--r--audio/py-pyliblo/Makefile2
-rw-r--r--audio/ripit/Makefile2
-rw-r--r--audio/ruby-taglib/Makefile2
-rw-r--r--audio/shairport/Makefile2
-rw-r--r--audio/spiralsynth/Makefile2
-rw-r--r--audio/squash/Makefile2
-rw-r--r--audio/streamtranscoder/Makefile2
-rw-r--r--audio/teamspeak_client/Makefile2
-rw-r--r--audio/timidity++/Makefile2
-rw-r--r--audio/voipong/Makefile2
29 files changed, 58 insertions, 0 deletions
diff --git a/audio/ampache/Makefile b/audio/ampache/Makefile
index 1a1f056fc8ff..c74f8625b582 100644
--- a/audio/ampache/Makefile
+++ b/audio/ampache/Makefile
@@ -26,6 +26,8 @@ SUB_LIST= PORTNAME=${PORTNAME} \
PORTDOCS= CHANGELOG README MIGRATION INSTALL
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/audio/autocd/Makefile b/audio/autocd/Makefile
index 65bbf6d59657..a096f6eb5bbb 100644
--- a/audio/autocd/Makefile
+++ b/audio/autocd/Makefile
@@ -20,6 +20,8 @@ PORTDOCS= README.rus.html
USE_RC_SUBR= autocd
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/audio/cmp3/Makefile b/audio/cmp3/Makefile
index 9450c14ed2fd..3f8941c9212c 100644
--- a/audio/cmp3/Makefile
+++ b/audio/cmp3/Makefile
@@ -28,6 +28,8 @@ PLIST_FILES= bin/cmp3 bin/rnmp3
RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
.endif
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/audio/cutmp3/Makefile b/audio/cutmp3/Makefile
index 5d6e4f7bf878..f28fbacafa3c 100644
--- a/audio/cutmp3/Makefile
+++ b/audio/cutmp3/Makefile
@@ -19,6 +19,8 @@ PLIST_FILES= bin/cutmp3
PORTDOCS= README README.timetable USAGE
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/audio/cymbaline/Makefile b/audio/cymbaline/Makefile
index cf0af30bf806..27107bc6468c 100644
--- a/audio/cymbaline/Makefile
+++ b/audio/cymbaline/Makefile
@@ -18,6 +18,8 @@ USE_PYDISTUTILS= yes
PLIST_FILES= bin/cymbaline
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/audio/dvda-author/Makefile b/audio/dvda-author/Makefile
index 3e2ea3c3632e..25d7f7f67723 100644
--- a/audio/dvda-author/Makefile
+++ b/audio/dvda-author/Makefile
@@ -33,6 +33,8 @@ CONFIGURE_ARGS= --with-flac=${LOCALBASE}/lib/libFLAC.so \
--enable-glibc
USE_CSTD= gnu89
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MDOCS}
diff --git a/audio/enscribe/Makefile b/audio/enscribe/Makefile
index b17f02d4b584..a94100a95563 100644
--- a/audio/enscribe/Makefile
+++ b/audio/enscribe/Makefile
@@ -25,6 +25,8 @@ LICENSE= GPLv2
PORTDOCS= README
PLIST_FILES= bin/enscribe
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-build:
diff --git a/audio/festival-freebsoft-utils/Makefile b/audio/festival-freebsoft-utils/Makefile
index a2352bd58a22..ad16cc496bed 100644
--- a/audio/festival-freebsoft-utils/Makefile
+++ b/audio/festival-freebsoft-utils/Makefile
@@ -20,6 +20,8 @@ PORTDOCS= ANNOUNCE NEWS README
INFO= ${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/audio/funktrackergold/Makefile b/audio/funktrackergold/Makefile
index 9bae263a8799..74942f6a6bbf 100644
--- a/audio/funktrackergold/Makefile
+++ b/audio/funktrackergold/Makefile
@@ -25,6 +25,8 @@ MAKE_ARGS= EXTRA_CFLAGS="${PTHREAD_CFLAGS}" \
PORTDOCS= INSTALL
PLIST_FILES= bin/funkgold
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/audio/id3mtag/Makefile b/audio/id3mtag/Makefile
index 0189519bf5de..d470d615b38e 100644
--- a/audio/id3mtag/Makefile
+++ b/audio/id3mtag/Makefile
@@ -21,6 +21,8 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/audio/libmpdclient/Makefile b/audio/libmpdclient/Makefile
index 05ad2ad09e8a..748663eeaef7 100644
--- a/audio/libmpdclient/Makefile
+++ b/audio/libmpdclient/Makefile
@@ -14,6 +14,8 @@ GNU_CONFIGURE= yes
USES= gmake pathfix
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/audio/linux-neroaaccodec/Makefile b/audio/linux-neroaaccodec/Makefile
index d4c88c4b6aa9..8277ce9445cb 100644
--- a/audio/linux-neroaaccodec/Makefile
+++ b/audio/linux-neroaaccodec/Makefile
@@ -30,6 +30,8 @@ PORTDOCS= NeroAAC_tut.pdf \
license.txt \
readme.txt
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/audio/listener/Makefile b/audio/listener/Makefile
index bc9ac9b54b03..7325d427c6d4 100644
--- a/audio/listener/Makefile
+++ b/audio/listener/Makefile
@@ -18,6 +18,8 @@ PORTDOCS= manual.html
PLIST_FILES= bin/setlistener bin/listener bin/listenersoundpipe \
etc/listener.conf.sample
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/audio/maplay/Makefile b/audio/maplay/Makefile
index 7089362af357..c6d2734c003b 100644
--- a/audio/maplay/Makefile
+++ b/audio/maplay/Makefile
@@ -19,6 +19,8 @@ NO_STAGE= yes
PLIST_FILES= bin/maplay
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/audio/mp3asm/Makefile b/audio/mp3asm/Makefile
index b7c7b614e5f8..acd065c7dcc3 100644
--- a/audio/mp3asm/Makefile
+++ b/audio/mp3asm/Makefile
@@ -20,6 +20,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-0.1
PLIST_FILES= bin/mp3asm
PORTDOCS= Changelog README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-extract:
diff --git a/audio/mp3c/Makefile b/audio/mp3c/Makefile
index c469b4f7484d..b7f39ff6c4c5 100644
--- a/audio/mp3c/Makefile
+++ b/audio/mp3c/Makefile
@@ -23,6 +23,8 @@ NO_STAGE= yes
MAN1= mp3c.1
MANCOMPRESSED= no
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/audio/pure-audio/Makefile b/audio/pure-audio/Makefile
index 81ff037cb76c..779049589d7a 100644
--- a/audio/pure-audio/Makefile
+++ b/audio/pure-audio/Makefile
@@ -31,6 +31,8 @@ PORTDOCS= README
PORTEXAMPLES= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
diff --git a/audio/py-eyed3/Makefile b/audio/py-eyed3/Makefile
index 7d4340ed4bc7..bf7b50144021 100644
--- a/audio/py-eyed3/Makefile
+++ b/audio/py-eyed3/Makefile
@@ -32,6 +32,8 @@ MANCOMPRESSED= yes
INSTALLS_EGGINFO= yes
PYDISTUTILS_PKGNAME= eyeD3
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/audio/py-openal/Makefile b/audio/py-openal/Makefile
index bc8df027db8a..adc8e5cf90c5 100644
--- a/audio/py-openal/Makefile
+++ b/audio/py-openal/Makefile
@@ -21,6 +21,8 @@ PYDISTUTILS_PKGNAME= PyOpenAL
WRKSRC= ${WRKDIR}/PyOpenAL-${PORTVERSION}
EXAMPLESDIR= ${PREFIX}/share/examples/py-openal
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/audio/py-pyliblo/Makefile b/audio/py-pyliblo/Makefile
index 55b294f13482..6c2156c24362 100644
--- a/audio/py-pyliblo/Makefile
+++ b/audio/py-pyliblo/Makefile
@@ -22,6 +22,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= dump_osc.1 send_osc.1
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/audio/ripit/Makefile b/audio/ripit/Makefile
index 0d1d9959df2a..5ee94bbbf6a1 100644
--- a/audio/ripit/Makefile
+++ b/audio/ripit/Makefile
@@ -29,6 +29,8 @@ USE_BZIP2= yes
SHEBANG_FILES= ripit.pl
perl_OLD_CMD= /usr/bin/env perl
+OPTIONS_DEFINE= EXAMPLES
+
.include <bsd.port.options.mk>
do-install:
diff --git a/audio/ruby-taglib/Makefile b/audio/ruby-taglib/Makefile
index 7a0ad9fc670b..8a2830bc47e6 100644
--- a/audio/ruby-taglib/Makefile
+++ b/audio/ruby-taglib/Makefile
@@ -25,6 +25,8 @@ NO_BUILD= yes
DOCS= README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/audio/shairport/Makefile b/audio/shairport/Makefile
index a4df021a90fa..3e7088b220c3 100644
--- a/audio/shairport/Makefile
+++ b/audio/shairport/Makefile
@@ -33,6 +33,8 @@ PORTDOCS= README.md
REV= b1cb9ea
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index e42cdca963c7..311315ef8f99 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -23,6 +23,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
DOC_FILES= CHANGES COPYING README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/audio/squash/Makefile b/audio/squash/Makefile
index 5786a47df64d..87c9f826c86f 100644
--- a/audio/squash/Makefile
+++ b/audio/squash/Makefile
@@ -24,6 +24,8 @@ USES= gmake
USE_RUBY= yes
MAKE_ARGS= CC=${CC}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/audio/streamtranscoder/Makefile b/audio/streamtranscoder/Makefile
index 13a356887d3e..268d0f48537f 100644
--- a/audio/streamtranscoder/Makefile
+++ b/audio/streamtranscoder/Makefile
@@ -24,6 +24,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/streamTranscoder
PORTDOCS= AUTHORS README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/audio/teamspeak_client/Makefile b/audio/teamspeak_client/Makefile
index 784c82b12958..188d1c56428e 100644
--- a/audio/teamspeak_client/Makefile
+++ b/audio/teamspeak_client/Makefile
@@ -39,6 +39,8 @@ DESKTOP_ENTRIES="TeamSpeak" \
"Network;Telephony;" \
false
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-extract:
diff --git a/audio/timidity++/Makefile b/audio/timidity++/Makefile
index bb3e9166a4d3..18f4ebbcb62d 100644
--- a/audio/timidity++/Makefile
+++ b/audio/timidity++/Makefile
@@ -30,6 +30,8 @@ PLIST_SUB+= TIMID_LIBDIR=${TIMID_LIBDIR} EUCJP_LOCALE=${EUCJP_LOCALE}
EUCJP_LOCALE= ja_JP.eucJP
TIMID_LIBDIR= lib/timidity
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if !defined(PKGNAMESUFFIX)
diff --git a/audio/voipong/Makefile b/audio/voipong/Makefile
index 56ae82d71925..7df54b35bd15 100644
--- a/audio/voipong/Makefile
+++ b/audio/voipong/Makefile
@@ -14,6 +14,8 @@ PORTDOCS= ALGORITHMS AUTHORS ChangeLog COPYING INSTALL KNOWN_BUGS \
LICENSE NEWS README THANKS TODO
NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
${MV} ${WRKSRC}/Makefile.bsd ${WRKSRC}/Makefile