aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/ample/Makefile2
-rw-r--r--audio/arts/Makefile2
-rw-r--r--audio/autocd/Makefile2
-rw-r--r--audio/blop/Makefile2
-rw-r--r--audio/bmp-faad/Makefile2
-rw-r--r--audio/boodler/Makefile2
-rw-r--r--audio/cuetools/Makefile2
-rw-r--r--audio/darkice/Makefile2
-rw-r--r--audio/faac/Makefile2
-rw-r--r--audio/faad/Makefile2
-rw-r--r--audio/festival+OGI/Makefile2
-rw-r--r--audio/festival/Makefile2
-rw-r--r--audio/flac/Makefile4
-rw-r--r--audio/flac123/Makefile2
-rw-r--r--audio/lame/Makefile2
-rw-r--r--audio/linux-arts/Makefile8
-rw-r--r--audio/linux-esound/Makefile2
-rw-r--r--audio/linux-f10-arts/Makefile8
-rw-r--r--audio/linux-f10-esound/Makefile2
-rw-r--r--audio/linux-f10-libaudiofile/Makefile2
-rw-r--r--audio/linux-f8-arts/Makefile8
-rw-r--r--audio/linux-f8-esound/Makefile2
-rw-r--r--audio/linux-f8-libaudiofile/Makefile2
-rw-r--r--audio/linux-libaudiofile/Makefile2
-rw-r--r--audio/lplayer/Makefile2
-rw-r--r--audio/mbrola/Makefile8
-rw-r--r--audio/mp3splt/Makefile2
-rw-r--r--audio/mp3wrap/Makefile2
-rw-r--r--audio/mpc/Makefile2
-rw-r--r--audio/mpeg4ip-faad/Makefile2
-rw-r--r--audio/mpg321/Makefile2
-rw-r--r--audio/normalize/Makefile2
-rw-r--r--audio/openal/Makefile2
-rw-r--r--audio/osalp/Makefile2
-rw-r--r--audio/resid/Makefile2
-rw-r--r--audio/rioutil/Makefile2
-rw-r--r--audio/sdl_mixer/Makefile2
-rw-r--r--audio/sdl_sound/Makefile2
-rw-r--r--audio/snack/Makefile2
-rw-r--r--audio/speex-devel/Makefile2
-rw-r--r--audio/speex/Makefile2
-rw-r--r--audio/swhplugins/Makefile2
-rw-r--r--audio/taglib/Makefile2
-rw-r--r--audio/tclmidi/Makefile2
-rw-r--r--audio/umix/Makefile2
-rw-r--r--audio/vorbisgain/Makefile2
-rw-r--r--audio/xhippo/Makefile2
-rw-r--r--audio/xmms-arts_output/Makefile2
-rw-r--r--audio/xmms-faad/Makefile2
-rw-r--r--audio/xmms-kde/Makefile2
-rw-r--r--audio/xmms-real-random/Makefile2
-rw-r--r--audio/xmms-volnorm/Makefile2
-rw-r--r--audio/xmp/Makefile2
-rw-r--r--audio/xsidplay/Makefile2
54 files changed, 67 insertions, 67 deletions
diff --git a/audio/ample/Makefile b/audio/ample/Makefile
index 3e60a77237d0..20a59e9b7a00 100644
--- a/audio/ample/Makefile
+++ b/audio/ample/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Allows you to listen to your own MP3's away from home
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= ample.1
MAN5= ample.conf.5 ample.html.5
diff --git a/audio/arts/Makefile b/audio/arts/Makefile
index b8035555f378..ccb2219ff77a 100644
--- a/audio/arts/Makefile
+++ b/audio/arts/Makefile
@@ -37,7 +37,7 @@ _NO_KDE_FINAL= yes
CFLAGS+= -DHAVE_VASPRINTF
CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
CONFIGURE_TARGET= # empty
-CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
+CONFIGURE_ARGS+=--build=${ARCH}-portbld-freebsd${OSREL} \
--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
OPTIONS= ESD "Enable esound support" off \
diff --git a/audio/autocd/Makefile b/audio/autocd/Makefile
index 1d449e1d0468..6188db4ffec6 100644
--- a/audio/autocd/Makefile
+++ b/audio/autocd/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= KOT@MATPOCKuH.Ru
COMMENT= Compact disc control utility
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= cdctl.1 acdplay.1
MAN8= autocd.8
MLINKS= cdctl.1 eject.1 cdctl.1 pause.1
diff --git a/audio/blop/Makefile b/audio/blop/Makefile
index f261cdaf87cc..472c9d4fd8a2 100644
--- a/audio/blop/Makefile
+++ b/audio/blop/Makefile
@@ -19,7 +19,7 @@ USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-ladspa-prefix="${LOCALBASE}"
diff --git a/audio/bmp-faad/Makefile b/audio/bmp-faad/Makefile
index 8b4bae29748d..934bafe694d5 100644
--- a/audio/bmp-faad/Makefile
+++ b/audio/bmp-faad/Makefile
@@ -32,7 +32,7 @@ USE_GMAKE= yes
USE_GNOME= gtk20
USE_REINPLACE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-xmms --with-mp4v2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} -DHAVE_GTK" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
diff --git a/audio/boodler/Makefile b/audio/boodler/Makefile
index 8843e08ed32e..325d3bcdccca 100644
--- a/audio/boodler/Makefile
+++ b/audio/boodler/Makefile
@@ -31,7 +31,7 @@ LDCONFIG_DIRS= %%PREFIX%%/share/boodler/boodle
DRIVER= FILE
.endif
-.if ${MACHINE_ARCH} == "amd64" || ${MACHINE_ARCH} == "ia64"
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
PIC= --PIC
.endif
diff --git a/audio/cuetools/Makefile b/audio/cuetools/Makefile
index 3117ecd4a0d6..b4d06acc0bc3 100644
--- a/audio/cuetools/Makefile
+++ b/audio/cuetools/Makefile
@@ -17,7 +17,7 @@ USE_REINPLACE= yes
USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= cuebreakpoints.1 cueconvert.1 cueprint.1
PORTDOCS= README
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
index ae7619865c3b..25b5708d80c8 100644
--- a/audio/darkice/Makefile
+++ b/audio/darkice/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-lame-prefix=${LOCALBASE} \
--with-vorbis-prefix=${LOCALBASE}
diff --git a/audio/faac/Makefile b/audio/faac/Makefile
index 57677145a433..38659e3a9116 100644
--- a/audio/faac/Makefile
+++ b/audio/faac/Makefile
@@ -24,7 +24,7 @@ AUTOMAKE_ARGS= --add-missing
USE_GMAKE= yes
USE_LIBTOOL_VER=13
USE_REINPLACE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
HAVECXX="yes"
diff --git a/audio/faad/Makefile b/audio/faad/Makefile
index 9512d29221ea..ea141b9136db 100644
--- a/audio/faad/Makefile
+++ b/audio/faad/Makefile
@@ -26,7 +26,7 @@ NO_CDROM= "Restrictive copyright (do not sell for profit)"
USE_AUTOMAKE_VER= 15
USE_AUTOHEADER_VER= 259
AUTOMAKE_ARGS= --add-missing
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/audio/festival+OGI/Makefile b/audio/festival+OGI/Makefile
index 1ad7a924de00..82fc50b36574 100644
--- a/audio/festival+OGI/Makefile
+++ b/audio/festival+OGI/Makefile
@@ -33,7 +33,7 @@ DIST_SUBDIR= festival
RESTRICTED= no-commercial-use
FESTIVAL= ${WRKSRC}/festival
-FESTIVAL_ARCH= ${MACHINE_ARCH:S/i386/ix86/}
+FESTIVAL_ARCH= ${ARCH:S/i386/ix86/}
FHOME= ${PREFIX}/share/festival
MAKE_ENV+= PKG_EST_HOME=${SPEECHTOOLS} \
EST_HOME=${SPEECHTOOLS} \
diff --git a/audio/festival/Makefile b/audio/festival/Makefile
index 485dbcfd9b79..48231b6236db 100644
--- a/audio/festival/Makefile
+++ b/audio/festival/Makefile
@@ -26,7 +26,7 @@ DIST_SUBDIR= festival
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-aa
-FESTIVAL_ARCH= ${MACHINE_ARCH:S/i386/ix86/}
+FESTIVAL_ARCH= ${ARCH:S/i386/ix86/}
USE_GCC= 2.95
WRKSRC= ${WRKDIR}
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index bc592aa61516..041f2aab7cd2 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -16,14 +16,14 @@ COMMENT= Free lossless audio codec
LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
-.if ${MACHINE_ARCH} == "i386"
+.if ${ARCH} == "i386"
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
.endif
USE_ICONV= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_TARGET= --target=${ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --enable-sse \
--with-libiconv-prefix="${LOCALBASE}" \
--with-ogg="${LOCALBASE}"
diff --git a/audio/flac123/Makefile b/audio/flac123/Makefile
index 7349aec2ddd2..5d04effa71f2 100644
--- a/audio/flac123/Makefile
+++ b/audio/flac123/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= FLAC.7:${PORTSDIR}/audio/flac \
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
PORTDOCS= README.remote
PLIST_FILES= bin/flac123
diff --git a/audio/lame/Makefile b/audio/lame/Makefile
index 3ace7b36186f..cbdc223f77ca 100644
--- a/audio/lame/Makefile
+++ b/audio/lame/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= lame
MAINTAINER= netchild@FreeBSD.org
COMMENT= ISO code based fast MP3 encoder kit
-.if ${MACHINE_ARCH} == "i386"
+.if ${ARCH} == "i386"
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
.endif
diff --git a/audio/linux-arts/Makefile b/audio/linux-arts/Makefile
index 108d6b92be4d..993aed970ff8 100644
--- a/audio/linux-arts/Makefile
+++ b/audio/linux-arts/Makefile
@@ -10,9 +10,9 @@ PORTVERSION= 1.0.3
PORTREVISION= 3
CATEGORIES= audio kde linux
MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
-MASTER_SITE_SUBDIR= 8.0/en/os/${MACHINE_ARCH}/RedHat/RPMS
+MASTER_SITE_SUBDIR= 8.0/en/os/${ARCH}/RedHat/RPMS
PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1$/-1/}-1.${MACHINE_ARCH}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1$/-1/}-1.${ARCH}
EXTRACT_SUFX= .rpm
EXTRACT_ONLY=
@@ -30,8 +30,8 @@ ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
-PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
-MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+PLIST= ${MASTERDIR}/pkg-plist.${ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
DBPATH= /var/lib/rpm
RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
diff --git a/audio/linux-esound/Makefile b/audio/linux-esound/Makefile
index e67027ca85ba..469d54630afd 100644
--- a/audio/linux-esound/Makefile
+++ b/audio/linux-esound/Makefile
@@ -15,7 +15,7 @@ COMMENT= RPM of esound
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libaudiofile.so.0:${PORTSDIR}/audio/linux-libaudiofile
-RPM_SET= esound-${PORTVERSION}-1.${MACHINE_ARCH}.rpm
+RPM_SET= esound-${PORTVERSION}-1.${ARCH}.rpm
.include "../../x11-toolkits/linux-gtk/Makefile"
diff --git a/audio/linux-f10-arts/Makefile b/audio/linux-f10-arts/Makefile
index 108d6b92be4d..993aed970ff8 100644
--- a/audio/linux-f10-arts/Makefile
+++ b/audio/linux-f10-arts/Makefile
@@ -10,9 +10,9 @@ PORTVERSION= 1.0.3
PORTREVISION= 3
CATEGORIES= audio kde linux
MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
-MASTER_SITE_SUBDIR= 8.0/en/os/${MACHINE_ARCH}/RedHat/RPMS
+MASTER_SITE_SUBDIR= 8.0/en/os/${ARCH}/RedHat/RPMS
PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1$/-1/}-1.${MACHINE_ARCH}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1$/-1/}-1.${ARCH}
EXTRACT_SUFX= .rpm
EXTRACT_ONLY=
@@ -30,8 +30,8 @@ ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
-PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
-MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+PLIST= ${MASTERDIR}/pkg-plist.${ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
DBPATH= /var/lib/rpm
RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
diff --git a/audio/linux-f10-esound/Makefile b/audio/linux-f10-esound/Makefile
index e67027ca85ba..469d54630afd 100644
--- a/audio/linux-f10-esound/Makefile
+++ b/audio/linux-f10-esound/Makefile
@@ -15,7 +15,7 @@ COMMENT= RPM of esound
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libaudiofile.so.0:${PORTSDIR}/audio/linux-libaudiofile
-RPM_SET= esound-${PORTVERSION}-1.${MACHINE_ARCH}.rpm
+RPM_SET= esound-${PORTVERSION}-1.${ARCH}.rpm
.include "../../x11-toolkits/linux-gtk/Makefile"
diff --git a/audio/linux-f10-libaudiofile/Makefile b/audio/linux-f10-libaudiofile/Makefile
index 35d35de5cb40..7516d7d0065e 100644
--- a/audio/linux-f10-libaudiofile/Makefile
+++ b/audio/linux-f10-libaudiofile/Makefile
@@ -13,6 +13,6 @@ CATEGORIES= audio linux
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of audiofile
-RPM_SET= audiofile-${PORTVERSION}-1.${MACHINE_ARCH}.rpm
+RPM_SET= audiofile-${PORTVERSION}-1.${ARCH}.rpm
.include "../../x11-toolkits/linux-gtk/Makefile"
diff --git a/audio/linux-f8-arts/Makefile b/audio/linux-f8-arts/Makefile
index 108d6b92be4d..993aed970ff8 100644
--- a/audio/linux-f8-arts/Makefile
+++ b/audio/linux-f8-arts/Makefile
@@ -10,9 +10,9 @@ PORTVERSION= 1.0.3
PORTREVISION= 3
CATEGORIES= audio kde linux
MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
-MASTER_SITE_SUBDIR= 8.0/en/os/${MACHINE_ARCH}/RedHat/RPMS
+MASTER_SITE_SUBDIR= 8.0/en/os/${ARCH}/RedHat/RPMS
PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1$/-1/}-1.${MACHINE_ARCH}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1$/-1/}-1.${ARCH}
EXTRACT_SUFX= .rpm
EXTRACT_ONLY=
@@ -30,8 +30,8 @@ ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
-PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
-MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+PLIST= ${MASTERDIR}/pkg-plist.${ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
DBPATH= /var/lib/rpm
RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
diff --git a/audio/linux-f8-esound/Makefile b/audio/linux-f8-esound/Makefile
index e67027ca85ba..469d54630afd 100644
--- a/audio/linux-f8-esound/Makefile
+++ b/audio/linux-f8-esound/Makefile
@@ -15,7 +15,7 @@ COMMENT= RPM of esound
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libaudiofile.so.0:${PORTSDIR}/audio/linux-libaudiofile
-RPM_SET= esound-${PORTVERSION}-1.${MACHINE_ARCH}.rpm
+RPM_SET= esound-${PORTVERSION}-1.${ARCH}.rpm
.include "../../x11-toolkits/linux-gtk/Makefile"
diff --git a/audio/linux-f8-libaudiofile/Makefile b/audio/linux-f8-libaudiofile/Makefile
index 35d35de5cb40..7516d7d0065e 100644
--- a/audio/linux-f8-libaudiofile/Makefile
+++ b/audio/linux-f8-libaudiofile/Makefile
@@ -13,6 +13,6 @@ CATEGORIES= audio linux
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of audiofile
-RPM_SET= audiofile-${PORTVERSION}-1.${MACHINE_ARCH}.rpm
+RPM_SET= audiofile-${PORTVERSION}-1.${ARCH}.rpm
.include "../../x11-toolkits/linux-gtk/Makefile"
diff --git a/audio/linux-libaudiofile/Makefile b/audio/linux-libaudiofile/Makefile
index 35d35de5cb40..7516d7d0065e 100644
--- a/audio/linux-libaudiofile/Makefile
+++ b/audio/linux-libaudiofile/Makefile
@@ -13,6 +13,6 @@ CATEGORIES= audio linux
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of audiofile
-RPM_SET= audiofile-${PORTVERSION}-1.${MACHINE_ARCH}.rpm
+RPM_SET= audiofile-${PORTVERSION}-1.${ARCH}.rpm
.include "../../x11-toolkits/linux-gtk/Makefile"
diff --git a/audio/lplayer/Makefile b/audio/lplayer/Makefile
index 64e879d88838..53a19bc10490 100644
--- a/audio/lplayer/Makefile
+++ b/audio/lplayer/Makefile
@@ -26,7 +26,7 @@ USE_QT_VER= 3
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-xmms-prefix=${X11BASE} --with-xinerama \
--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/audio/mbrola/Makefile b/audio/mbrola/Makefile
index 0921b1f2c475..1a884d4463a5 100644
--- a/audio/mbrola/Makefile
+++ b/audio/mbrola/Makefile
@@ -45,13 +45,13 @@ do-patch:
do-install:
.if defined(USE_LINUX)
-.if (${MACHINE_ARCH} == "alpha")
+.if (${ARCH} == "alpha")
@${INSTALL_PROGRAM} ${WRKSRC}/mbrola-linux-alpha ${PREFIX}/bin/mbrola
-.elseif (${MACHINE_ARCH} == "i386")
+.elseif (${ARCH} == "i386")
@${INSTALL_PROGRAM} ${WRKSRC}/mbrola-linux-i386 ${PREFIX}/bin/mbrola
-.elseif (${MACHINE_ARCH} == "ppc")
+.elseif (${ARCH} == "ppc")
@${INSTALL_PROGRAM} ${WRKSRC}/mbrola206a-linux-ppc ${PREFIX}/bin/mbrola
-.elseif (${MACHINE_ARCH} == "sparc64")
+.elseif (${ARCH} == "sparc64")
@${INSTALL_PROGRAM} ${WRKSRC}/mbrola-SuSElinux-ultra1.dat \
${PREFIX}/bin/mbrola
.endif
diff --git a/audio/mp3splt/Makefile b/audio/mp3splt/Makefile
index 7869fe2021eb..c8b17d56ef73 100644
--- a/audio/mp3splt/Makefile
+++ b/audio/mp3splt/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GETOPT_LONG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/audio/mp3wrap/Makefile b/audio/mp3wrap/Makefile
index 0a05d24f857c..5c2b0f187303 100644
--- a/audio/mp3wrap/Makefile
+++ b/audio/mp3wrap/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= q@uni.de
COMMENT= Utility to merge mp3 files (and other formats)
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/audio/mpc/Makefile b/audio/mpc/Makefile
index abda9cc3ac7f..114e015a245e 100644
--- a/audio/mpc/Makefile
+++ b/audio/mpc/Makefile
@@ -22,7 +22,7 @@ MAN1= mpc.1
.include <bsd.port.pre.mk>
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
diff --git a/audio/mpeg4ip-faad/Makefile b/audio/mpeg4ip-faad/Makefile
index f2f3dea23174..0b59430f7314 100644
--- a/audio/mpeg4ip-faad/Makefile
+++ b/audio/mpeg4ip-faad/Makefile
@@ -25,7 +25,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_AUTOMAKE_VER= 15
USE_AUTOHEADER_VER= 253
AUTOMAKE_ARGS= --add-missing
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/audio/mpg321/Makefile b/audio/mpg321/Makefile
index 86dd7eabefca..2521f732e21c 100644
--- a/audio/mpg321/Makefile
+++ b/audio/mpg321/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao \
mad.2:${PORTSDIR}/audio/libmad
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-mpg123-symlink
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/audio/normalize/Makefile b/audio/normalize/Makefile
index c7c3f6dcd358..7af40bb03fbb 100644
--- a/audio/normalize/Makefile
+++ b/audio/normalize/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.if defined(WITH_XMMS)
PLIST_SUB+= XMMS=""
diff --git a/audio/openal/Makefile b/audio/openal/Makefile
index edfe882d83b8..93f3985dff9e 100644
--- a/audio/openal/Makefile
+++ b/audio/openal/Makefile
@@ -18,7 +18,7 @@ INFO= openal
WRKSRC= ${WRKDIR}/${DISTNAME}/linux
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_GNOME= pkgconfig
INSTALLS_SHLIB= yes
diff --git a/audio/osalp/Makefile b/audio/osalp/Makefile
index 221e959511f8..26f1e9b0c854 100644
--- a/audio/osalp/Makefile
+++ b/audio/osalp/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CFLAGS+= -fPIC -DPIC
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
diff --git a/audio/resid/Makefile b/audio/resid/Makefile
index e075ce1d685c..f4f6870b9fe0 100644
--- a/audio/resid/Makefile
+++ b/audio/resid/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Cycle-based SID emulator engine
USE_INC_LIBTOOL_VER= 13
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-shared
INSTALLS_SHLIB= yes
diff --git a/audio/rioutil/Makefile b/audio/rioutil/Makefile
index 606bcf7fe9da..0e1799cd11be 100644
--- a/audio/rioutil/Makefile
+++ b/audio/rioutil/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb
USE_GETOPT_LONG= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
index 6e46e3c0fcb0..d50ff1c026ac 100644
--- a/audio/sdl_mixer/Makefile
+++ b/audio/sdl_mixer/Makefile
@@ -21,7 +21,7 @@ USE_SDL= sdl
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
INSTALLS_SHLIB= yes
diff --git a/audio/sdl_sound/Makefile b/audio/sdl_sound/Makefile
index 96506d499e17..ca12184cfe9b 100644
--- a/audio/sdl_sound/Makefile
+++ b/audio/sdl_sound/Makefile
@@ -18,7 +18,7 @@ COMMENT= A SDL audio library and player for some popular sound file formats
USE_SDL= sdl
USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 13
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
diff --git a/audio/snack/Makefile b/audio/snack/Makefile
index 8c75e9881458..4861e014061c 100644
--- a/audio/snack/Makefile
+++ b/audio/snack/Makefile
@@ -23,7 +23,7 @@ OPTIONS= VORBIS "Support for OGG/Vorbis Audio" off
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
--with-tk=${LOCALBASE}/lib/tk8.4
MAKE_ENV= prefix=${PREFIX} exec_prefix=${PREFIX}
diff --git a/audio/speex-devel/Makefile b/audio/speex-devel/Makefile
index e50b6b5e170e..a5f4f1aaa968 100644
--- a/audio/speex-devel/Makefile
+++ b/audio/speex-devel/Makefile
@@ -25,7 +25,7 @@ USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER= 15
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/audio/speex/Makefile b/audio/speex/Makefile
index 098dba1bca08..3c12e5a7ae52 100644
--- a/audio/speex/Makefile
+++ b/audio/speex/Makefile
@@ -26,7 +26,7 @@ USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 13
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/audio/swhplugins/Makefile b/audio/swhplugins/Makefile
index 58b4d9db089a..ca9e59c7a9b9 100644
--- a/audio/swhplugins/Makefile
+++ b/audio/swhplugins/Makefile
@@ -24,7 +24,7 @@ ONLY_FOR_ARCHS= i386 amd64
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
diff --git a/audio/taglib/Makefile b/audio/taglib/Makefile
index 5d25929c7312..e8b19deb8981 100644
--- a/audio/taglib/Makefile
+++ b/audio/taglib/Makefile
@@ -19,6 +19,6 @@ USE_INC_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET=
-CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --build=${ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/audio/tclmidi/Makefile b/audio/tclmidi/Makefile
index 54c554241970..fc275cc9fa5a 100644
--- a/audio/tclmidi/Makefile
+++ b/audio/tclmidi/Makefile
@@ -17,7 +17,7 @@ COMMENT= A language designed for creating and editing standard MIDI files
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
-.if ${MACHINE_ARCH} == "ia64" || ${MACHINE_ARCH} == "sparc64"
+.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
IGNORE= "ignored due to cast from pointer to integer of different size"
.endif
diff --git a/audio/umix/Makefile b/audio/umix/Makefile
index ee0269bd7da1..6c05da703985 100644
--- a/audio/umix/Makefile
+++ b/audio/umix/Makefile
@@ -17,7 +17,7 @@ COMMENT= Advanced tool for adjusting soundcard mixers, replacement for aumix
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= umix.1
PLIST_FILES= bin/umix
diff --git a/audio/vorbisgain/Makefile b/audio/vorbisgain/Makefile
index 8711abceecbc..c242ef9182e9 100644
--- a/audio/vorbisgain/Makefile
+++ b/audio/vorbisgain/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
USE_ZIP= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/audio/xhippo/Makefile b/audio/xhippo/Makefile
index 018b3ff2174d..059954b6448f 100644
--- a/audio/xhippo/Makefile
+++ b/audio/xhippo/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
USE_GNOME= gtk12
WANT_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
DOCS= ChangeLog gnu-xhippo.html screenshot.jpeg xhippo.html.gz \
xhippo.info.gz xhippo.ps.gz xhippo.sgml xhippo.txt.gz
diff --git a/audio/xmms-arts_output/Makefile b/audio/xmms-arts_output/Makefile
index 334632e0fcd0..38befb46d08b 100644
--- a/audio/xmms-arts_output/Makefile
+++ b/audio/xmms-arts_output/Makefile
@@ -22,7 +22,7 @@ USE_X_PREFIX= yes
USE_GNOME= gtk12
USE_INC_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
PLIST_FILES= lib/xmms/Output/libarts.so \
bin/xmms-arts-helper
diff --git a/audio/xmms-faad/Makefile b/audio/xmms-faad/Makefile
index 297d05207cb4..5dbf8a798340 100644
--- a/audio/xmms-faad/Makefile
+++ b/audio/xmms-faad/Makefile
@@ -33,7 +33,7 @@ USE_GNOME= gtk12
USE_GMAKE= yes
USE_REINPLACE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-xmms --with-mp4v2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} -DHAVE_GTK" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
diff --git a/audio/xmms-kde/Makefile b/audio/xmms-kde/Makefile
index 758ad05318f1..67f89c4d25da 100644
--- a/audio/xmms-kde/Makefile
+++ b/audio/xmms-kde/Makefile
@@ -23,7 +23,7 @@ USE_INC_LIBTOOL_VER= 13
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET=
-CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
+CONFIGURE_ARGS+=--build=${ARCH}-portbld-freebsd${OSREL} \
--with-xmms-prefix=${X11BASE}
USE_GNOME= gtk12
diff --git a/audio/xmms-real-random/Makefile b/audio/xmms-real-random/Makefile
index d878ad8b50b7..9adac5a1533f 100644
--- a/audio/xmms-real-random/Makefile
+++ b/audio/xmms-real-random/Makefile
@@ -23,7 +23,7 @@ USE_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
USE_X_PREFIX= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS='${CFLAGS}'
post-patch:
diff --git a/audio/xmms-volnorm/Makefile b/audio/xmms-volnorm/Makefile
index eedf8f7f25b4..3ec1448993ec 100644
--- a/audio/xmms-volnorm/Makefile
+++ b/audio/xmms-volnorm/Makefile
@@ -21,7 +21,7 @@ PLIST_FILES= lib/xmms/Effect/libnormvol.so
USE_X_PREFIX= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_TARGET= --target=${ARCH}-unknown-freebsd${OSREL}
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/audio/xmp/Makefile b/audio/xmp/Makefile
index 362d0c06fd71..2a610973404f 100644
--- a/audio/xmp/Makefile
+++ b/audio/xmp/Makefile
@@ -29,7 +29,7 @@ CFLAGS+= -fPIC
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 500013 || ${MACHINE_ARCH} == "alpha"
+.if ${OSVERSION} > 500013 || ${ARCH} == "alpha"
USE_GNOME+= esound
CONFIGURE_ARGS+= --disable-oss --enable-esd
PKGNAMESUFFIX= -esound
diff --git a/audio/xsidplay/Makefile b/audio/xsidplay/Makefile
index 5d40ad9021b1..3ad52f96d012 100644
--- a/audio/xsidplay/Makefile
+++ b/audio/xsidplay/Makefile
@@ -38,7 +38,7 @@ MAN1= xsidplay.1
.include <bsd.port.pre.mk>
-.if ${MACHINE_ARCH} == "alpha"
+.if ${ARCH} == "alpha"
CFLAGS+= -O0
.endif