aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/rawrec/Makefile42
-rw-r--r--audio/rawrec/distinfo1
-rw-r--r--audio/rawrec/pkg-comment1
-rw-r--r--audio/rawrec/pkg-descr5
-rw-r--r--audio/rawrec/pkg-plist2
6 files changed, 52 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index a5a968e5fca3..d27e6ed305e4 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -176,6 +176,7 @@
SUBDIR += quelcom
SUBDIR += radio
SUBDIR += raproxy
+ SUBDIR += rawrec
SUBDIR += rebler
SUBDIR += replay
SUBDIR += rio
diff --git a/audio/rawrec/Makefile b/audio/rawrec/Makefile
new file mode 100644
index 000000000000..d605ae6acb32
--- /dev/null
+++ b/audio/rawrec/Makefile
@@ -0,0 +1,42 @@
+# ex:ts=8
+# Ports collection makefile for: rawrec
+# Date created: May 9, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rawrec
+PORTVERSION= 0.9.97
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= apps/sound/recorders \
+ ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+CFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+USE_GMAKE= yes
+
+MAN1= rawrec.1
+MLINKS= rawrec.1 rawplay.1
+
+post-patch:
+ @${PERL} -pi -e "s,^CFLAGS =,CFLAGS+=,g ; \
+ s,^LDFLAGS =,LDFLAGS+=,g ; \
+ s,-lpthread,${PTHREAD_LIBS},g ; \
+ s,/usr/local,${PREFIX},g" ${WRKSRC}/Makefile
+ @${GREP} -lR "linux/" ${WRKSRC} | ${XARGS} \
+ ${PERL} -pi -e "s,linux/,machine/,g"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rawrec ${PREFIX}/bin
+ ${LN} -fs ${PREFIX}/bin/rawrec ${PREFIX}/bin/rawplay
+ ${INSTALL_MAN} ${WRKSRC}/../docs/user/rawrec.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/audio/rawrec/distinfo b/audio/rawrec/distinfo
new file mode 100644
index 000000000000..8874c89f381c
--- /dev/null
+++ b/audio/rawrec/distinfo
@@ -0,0 +1 @@
+MD5 (rawrec-0.9.97.tar.gz) = 67a219555cfbf0fff1eb62b1e03f3e6b
diff --git a/audio/rawrec/pkg-comment b/audio/rawrec/pkg-comment
new file mode 100644
index 000000000000..6a37805c22c2
--- /dev/null
+++ b/audio/rawrec/pkg-comment
@@ -0,0 +1 @@
+rawrec/rawplay threaded audio
diff --git a/audio/rawrec/pkg-descr b/audio/rawrec/pkg-descr
new file mode 100644
index 000000000000..11f798d9e88c
--- /dev/null
+++ b/audio/rawrec/pkg-descr
@@ -0,0 +1,5 @@
+rawrec provides a simple, minimalist way to record or play back raw audio
+data from the command line. It can work with files or standard IO, and so
+can provide a simple buffered shell audio interface for other programs.
+
+WWW: http://rawrec.sourceforge.net/
diff --git a/audio/rawrec/pkg-plist b/audio/rawrec/pkg-plist
new file mode 100644
index 000000000000..a00182c6dfea
--- /dev/null
+++ b/audio/rawrec/pkg-plist
@@ -0,0 +1,2 @@
+bin/rawplay
+bin/rawrec