aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/juk/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/audio/juk/Makefile b/audio/juk/Makefile
index 72958693ae4f..94ab03fc0a2e 100644
--- a/audio/juk/Makefile
+++ b/audio/juk/Makefile
@@ -20,7 +20,13 @@ RUN_DEPENDS= ${LOCALBASE}/lib/kde3/kfile_mp3.so:${PORTSDIR}/multimedia/kdemultim
USE_KDELIBS_VER=3
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-transform-name=''
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_REINPLACE= yes
+
+CONFIGURE_TARGET= --build=${ARCH}-portsbld-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-pedantic ||g; \
+ s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>