aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/aften/Makefile27
1 files changed, 13 insertions, 14 deletions
diff --git a/audio/aften/Makefile b/audio/aften/Makefile
index 649283cae144..bcae5fca98db 100644
--- a/audio/aften/Makefile
+++ b/audio/aften/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: aften
-# Date created: April 3, 2010
-# Whom: Gabor Zahemszky <Gabor@Zahemszky.HU>
-#
+# Created by: Gabor Zahemszky <Gabor@Zahemszky.HU>
# $FreeBSD$
-#
PORTNAME= aften
PORTVERSION= 0.0.8
@@ -22,24 +18,27 @@ INSTALL_WRKSRC= ${BUILDDIR}
USE_CMAKE= yes
CMAKE_ARGS+= -DCMAKE_INSTALL_PREFIX:STRING="${PREFIX}"
-OPTIONS= SHARED_LIB "Build with shared library" off \
- CXX_BINDINGS "Build with C++ bindings" off \
- DOUBLE "Use double precision" off
+OPTIONS_DEFINE= SHARED_LIB CXX_BINDINGS DOUBLE
+OPTIONS_DEFAULT=
-.include <bsd.port.pre.mk>
+SHARED_LIB_DESC= Build with shared library
+CXX_BINDINGS_DESC= Build with C++ bindings
+DOUBLE_DESC= Use double precision
-.if defined(WITH_SHARED_LIB)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSHARED_LIB}
CMAKE_ARGS+= -DSHARED:BOOL=ON
.endif
-.if defined(WITH_CXX_BINDINGS)
+.if ${PORT_OPTIONS:MCXX_BINDINGS}
CMAKE_ARGS+= -DBINDINGS_CXX:BOOL=ON
PLIST_SUB+= CXX=""
.else
PLIST_SUB+= CXX="@comment "
.endif
-.if defined(WITH_SHARED_LIB) || defined(WITH_CXX_BINDINGS)
+.if ${PORT_OPTIONS:MSHARED_LIB} || ${PORT_OPTIONS:MCXX_BINDINGS}
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
PLIST_SUB+= LIBS=""
USE_LDCONFIG= yes
@@ -47,7 +46,7 @@ USE_LDCONFIG= yes
PLIST_SUB+= LIBS="@comment "
.endif
-.if defined(WITH_DOUBLE)
+.if ${PORT_OPTIONS:MDOUBLE}
CMAKE_ARGS+= -DDOUBLE:BOOL=ON
.endif
@@ -55,4 +54,4 @@ do-configure:
@${MKDIR} ${BUILDDIR}
@cd ${BUILDDIR}; ${SETENV} ${CMAKE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ..
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>