aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/denemo/Makefile4
-rw-r--r--audio/rezound/Makefile4
-rw-r--r--audio/sfront/Makefile3
3 files changed, 6 insertions, 5 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index 90b391dc016b..71844d7d944f 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= denemo
PORTVERSION= 0.7.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +18,7 @@ COMMENT= Graphical score editor
USE_XLIB= yes
USE_GNOME= gnometarget gtk20 libxml2
USE_GCC= 3.4+
-USE_BISON= yes
+USE_BISON= build
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index e9cbc7e62cac..4ff43cbf1c93 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rezound
DISTVERSION= 0.12.3beta
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,9 +15,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Graphical audio file editor
-BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
LIB_DEPENDS= FOX-1.4:${PORTSDIR}/x11-toolkits/fox14
+USE_BISON= build
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
diff --git a/audio/sfront/Makefile b/audio/sfront/Makefile
index 1d673ea7d685..0a8f4a9e7d4e 100644
--- a/audio/sfront/Makefile
+++ b/audio/sfront/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sfront
PORTVERSION= 0.91
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://critical.ch/distfiles/ \
http://energy.critical.ch/distfiles/
@@ -18,7 +19,7 @@ PORTDOCS= book sfman
WRKSRC= ${WRKDIR}/${PORTNAME}/src
-USE_BISON= yes
+USE_BISON= build
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
ALL_TARGET= ${PORTNAME}