aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/espeak/Makefile2
-rw-r--r--audio/espeak/distinfo6
-rw-r--r--audio/espeak/files/patch-src-Makefile33
-rw-r--r--audio/espeak/files/patch-src-speech.h11
-rw-r--r--audio/espeak/pkg-plist4
5 files changed, 29 insertions, 27 deletions
diff --git a/audio/espeak/Makefile b/audio/espeak/Makefile
index d1cd1f936a8a..02578dfb686f 100644
--- a/audio/espeak/Makefile
+++ b/audio/espeak/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= espeak
-PORTVERSION= 1.16
+PORTVERSION= 1.17
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/audio/espeak/distinfo b/audio/espeak/distinfo
index 077ecccd19eb..c0cc6c3afbff 100644
--- a/audio/espeak/distinfo
+++ b/audio/espeak/distinfo
@@ -1,3 +1,3 @@
-MD5 (espeak-1.16-source.zip) = c376ea94cddda90b093f231926f7ba44
-SHA256 (espeak-1.16-source.zip) = cdb213b50bff0c092a4d1941038eadac831251acee64acb48943e13ccae3471b
-SIZE (espeak-1.16-source.zip) = 528920
+MD5 (espeak-1.17-source.zip) = b55432e1f0b7cea1276f25281714c771
+SHA256 (espeak-1.17-source.zip) = fa68ef2cef826005937f1711f881050298e8033cf85d1ce0dcd6a61566dfc5d4
+SIZE (espeak-1.17-source.zip) = 546677
diff --git a/audio/espeak/files/patch-src-Makefile b/audio/espeak/files/patch-src-Makefile
index 108f5bfaaa8f..fce1df3b2b35 100644
--- a/audio/espeak/files/patch-src-Makefile
+++ b/audio/espeak/files/patch-src-Makefile
@@ -1,6 +1,15 @@
---- src/Makefile Tue Sep 19 23:56:53 2006
-+++ src/Makefile.port Fri Sep 22 13:14:34 2006
-@@ -11,7 +11,7 @@
+--- src/Makefile Thu Nov 16 23:59:58 2006
++++ src/Makefile.port Fri Nov 17 23:23:12 2006
+@@ -1,7 +1,7 @@
+ BINDIR=/usr/local/bin
+ INCDIR=/usr/include/espeak
+ LIBDIR=/usr/lib
+-DATADIR=/usr/share/espeak-data
++DATADIR=%%DATADIR%%
+
+ RELEASE = 1.17
+ BIN_NAME = speak
+@@ -26,7 +26,7 @@
SRCS1=$(speak_SOURCES)
OBJS1=$(patsubst %.cpp,%.o,$(SRCS1))
@@ -9,27 +18,27 @@
SRCS2=$(libespeak_SOURCES)
OBJS2=$(patsubst %.cpp,x_%.o,$(SRCS2))
-@@ -23,19 +23,19 @@
- mv libespeak.so libespeak.so.1.1.14
+@@ -39,19 +39,19 @@
+ mv $(LIB_NAME) $(LIB_NAME).$(LIBTAG)
.cpp.o:
-- $(CXX) $(CXXFLAGS) -O2 -Wall -pedantic -I. -c -fno-exceptions $<
-+ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(PTHREAD_CFLAGS) -Wall -pedantic -I. -c -fno-exceptions $<
+- $(CXX) $(CXXFLAGS) -D PATH_ESPEAK_DATA=\"$(DATADIR)\" -Wall -pedantic -I. -c -fno-exceptions $<
++ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(PTHREAD_CFLAGS)-D PATH_ESPEAK_DATA=\"$(DATADIR)\" -Wall -pedantic -I. -c -fno-exceptions $<
- speak: $(OBJS1)
+ $(BIN_NAME): $(OBJS1)
- $(CXX) -o $@ $(OBJS1) $(LIBS1)
+ $(CXX) $(PTHREAD_LIBS) -o $@ $(OBJS1) $(LIBS1)
x_%.o: %.cpp
-- $(CXX) $(CXXFLAGS) -O2 -Wall -fpic -fvisibility=hidden -pedantic \
+- $(CXX) $(CXXFLAGS) -Wall -fpic -fvisibility=hidden -pedantic \
+ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(PTHREAD_CFLAGS) -Wall -fPIC -pedantic \
-I. -D LIBRARY -c -fno-exceptions $< -o x_$*.o
- libespeak.so: $(OBJS2)
-- $(CXX) -shared -Wl,-soname,libespeak.so.1 -o $@ $(OBJS2) $(LIBS2)
-+ $(CXX) $(PTHREAD_LIBS) -shared -Wl,-soname,libespeak.so.1 -o $@ $(OBJS2) $(LIBS2)
+ $(LIB_NAME): $(OBJS2)
+- $(CXX) -shared -Wl,-soname,$(LIB_NAME).$(LIB_VERSION) -o $@ $(OBJS2) $(LIBS2)
++ $(CXX) $(PTHREAD_LIBS) -shared -Wl,-soname,$(LIB_NAME).$(LIB_VERSION) -o $@ $(OBJS2) $(LIBS2)
clean:
rm -f *.o *~
diff --git a/audio/espeak/files/patch-src-speech.h b/audio/espeak/files/patch-src-speech.h
deleted file mode 100644
index 405fb7a64650..000000000000
--- a/audio/espeak/files/patch-src-speech.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/speech.h Tue Oct 3 00:51:13 2006
-+++ src/speech.h.port Wed Oct 11 23:43:20 2006
-@@ -36,7 +36,7 @@
- #endif
-
- // will look for espeak_data directory here, and also in user's home directory
--#define PATH_ESPEAK_DATA "/usr/share/espeak-data"
-+#define PATH_ESPEAK_DATA "%%DATADIR%%/espeak-data"
-
- typedef unsigned short USHORT;
- typedef unsigned char UCHAR;
diff --git a/audio/espeak/pkg-plist b/audio/espeak/pkg-plist
index 482482ca6de0..f4b57f0032fa 100644
--- a/audio/espeak/pkg-plist
+++ b/audio/espeak/pkg-plist
@@ -27,10 +27,12 @@ lib/%%ESPEAK_LIBRARY%%
%%DATADIR%%/espeak-data/es_dict
%%DATADIR%%/espeak-data/fi_dict
%%DATADIR%%/espeak-data/it_dict
+%%DATADIR%%/espeak-data/nl_dict
%%DATADIR%%/espeak-data/phondata
%%DATADIR%%/espeak-data/phonindex
%%DATADIR%%/espeak-data/phontab
%%DATADIR%%/espeak-data/pl_dict
+%%DATADIR%%/espeak-data/pt_dict
%%DATADIR%%/espeak-data/ru_dict
%%DATADIR%%/espeak-data/voices/af
%%DATADIR%%/espeak-data/voices/cy
@@ -57,7 +59,9 @@ lib/%%ESPEAK_LIBRARY%%
%%DATADIR%%/espeak-data/voices/es
%%DATADIR%%/espeak-data/voices/fi
%%DATADIR%%/espeak-data/voices/it
+%%DATADIR%%/espeak-data/voices/nl
%%DATADIR%%/espeak-data/voices/pl
+%%DATADIR%%/espeak-data/voices/pt
%%DATADIR%%/espeak-data/voices/ru
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%