aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/dbs
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/dbs')
-rw-r--r--benchmarks/dbs/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/benchmarks/dbs/Makefile b/benchmarks/dbs/Makefile
index 1eade3683d6f..2fd6ced0a1a7 100644
--- a/benchmarks/dbs/Makefile
+++ b/benchmarks/dbs/Makefile
@@ -23,6 +23,12 @@ DOCS= dbs.man dbs.man.jis dbs_paper.ps Copyright
EXDIR= ${PREFIX}/share/examples/dbs/
EXS= TCP2.cmd TCPvsMPEG.cmd
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 900000
+BROKEN= does not compile on FreeBSD 9.X
+.endif
+
do-build:
cd ${WRKSRC}/src; ${MAKE} dir
cd ${WRKSRC}/obj/${OPSYS}; ${MAKE} ${ALL_TARGET} PREFIX=${PREFIX}
@@ -37,4 +43,4 @@ do-install:
cd ${WRKSRC}/doc; ${CP} -p ${DOCS} ${DOCDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>