aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/filebench/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/filebench/Makefile')
-rw-r--r--benchmarks/filebench/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/benchmarks/filebench/Makefile b/benchmarks/filebench/Makefile
new file mode 100644
index 000000000000..1256d7d9eb9e
--- /dev/null
+++ b/benchmarks/filebench/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: filebench
+# Date created: Jan 6, 2011
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= filebench
+PORTVERSION= 1.4.8.0.8
+CATEGORIES= benchmarks
+MASTER_SITES= http://www.fsl.cs.sunysb.edu/~vass/filebench/
+DISTNAME= go_filebench-1.4.8.fsl.0.8
+
+MAINTAINER= tom@tomjudge.com
+COMMENT= Performance Test of Filesystem I/O
+
+ONLY_FOR_ARCHS= amd64 i386 ia64 ppc
+
+GNU_CONFIGURE= yes
+LICENSE= CDDL
+
+do-install:
+ ( cd ${WRKSRC} && make install-binPROGRAMS )
+.if !defined(NOPORTDATA)
+ (cd ${WRKSRC} && make install-data )
+.endif
+
+.include <bsd.port.mk>