aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/fio
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/fio')
-rw-r--r--benchmarks/fio/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
index d40039cadfed..b79811a3e9b9 100644
--- a/benchmarks/fio/Makefile
+++ b/benchmarks/fio/Makefile
@@ -18,6 +18,18 @@ GNUPLOT_DESC= Support for plotting graphs
GNUPLOT_BUILD_DEPENDS= ${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot
+.include <bsd.port.options.mk>
+
+if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000013
+USES+= bison
+MAKE_ARGS+= YACC=${LOCALBASE}/bin/bison
+.endif
+
+if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000033
+BUILD_DEPENDS+= flex>0:${PORTSDIR}/textproc/flex
+MAKE_ARGS+= LEX=${LOCALBASE}/bin/flex
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fio ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/tools/fio_generate_plots ${STAGEDIR}${PREFIX}/bin