aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/forkbomb
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/forkbomb')
-rw-r--r--benchmarks/forkbomb/Makefile4
-rw-r--r--benchmarks/forkbomb/files/patch-Makefile11
2 files changed, 15 insertions, 0 deletions
diff --git a/benchmarks/forkbomb/Makefile b/benchmarks/forkbomb/Makefile
index b784505e5c44..f167ae3136bf 100644
--- a/benchmarks/forkbomb/Makefile
+++ b/benchmarks/forkbomb/Makefile
@@ -15,6 +15,10 @@ MAINTAINER= hsn@netmag.cz
COMMENT= System stress testing tool
USE_GETOPT_LONG=yes
+
+MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
MAN8= forkbomb.8
.include <bsd.port.mk>
diff --git a/benchmarks/forkbomb/files/patch-Makefile b/benchmarks/forkbomb/files/patch-Makefile
new file mode 100644
index 000000000000..89899088deb3
--- /dev/null
+++ b/benchmarks/forkbomb/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Thu Jan 29 14:10:22 2004
++++ Makefile Thu Jan 29 14:10:51 2004
+@@ -16,7 +16,7 @@
+ install -m 444 forkbomb.8 $(DESTDIR)$(PREFIX)/man/man8
+
+ forkbomb: forkbomb.c Makefile
+- ${CC} $(CFLAGS) $(LDFLAGS) -o forkbomb forkbomb.c $(LIBS)
++ ${CC} $(CFLAGS) ${CPPFLAGS} $(LDFLAGS) -o forkbomb forkbomb.c $(LIBS)
+
+ clean:
+ rm -f *.o forkbomb *~ *core tags